


• A word processor is software or a device that allows 
users to create, edit, and print documents. It enables 
you to write text, store it electronically, display it on a 
screen, modify it by entering commands and 
characters from the keyboard, and print it.



• Working With Text and Styles
Microsoft Word is a word processor, which means 
that it's designed primarily for text-based 
documents. These can be business reports, 
student papers, informal notes from a call or a 
lecture, or letters to friends and relatives.

• Saving and Printing
After you create a document in Word, you usually 
want to save it for later access, send to someone, 
print it out, or any combination of these uses.



• Word and Compatibility
Microsoft Word has been designed for years to 
maximize compatibility between versions. Typically, 
versions of Microsoft Word can open files created in 
previous versions of the software and save files in 
formats usable by earlier versions.

• Preview Facility : Before getting a print of our 
document, we can get a preview of document. If 
mistakes are there, we can change the document.

• Easy Typing : In MS Word, typing is so easy because
– we need not click enter button after the end of a line as in 

case of type writer.



• Adding, Removing and Copying Test : Documents can 
be modified easily in MS Office. We need not strike off 
any word as in the case of type writer. We can easily 
place a new word in place of existing one. The new 
word or paragraphs will automatically be adjusted in 
the place of deleted or modified text. We can also copy 
a part or whole of the matter from one file or 
document to another document.

• Spell Check of words : The spellings of words in the 
document can be rectified automatically. We can find 
alternative words to our typed words. Not only that, 
even the grammatical errors can also be rectified in 
word processor



• Headers and Footers : A Header is the text appearing 
above the document and Footer is the text appearing 
below the document. In Word Processor, we can create 
these Headers and Footers in the document easily.

• Creation of Tables : Tables can be created neatly in 
word processor. If you give directions for required 
number of rows and columns, word processor provides 
a ready made table to work .

• Bullets and Numbering : Bullets are special symbols 
which can be put for different points in a document 
whereas numbers are ascending figures like1, 2, 3, ...... 
etc. Which can be assigned to different points in the 
paragraph or document. In word processor we can 
assign such bullets or numbers automatically with a 
single command.



• Home: Clipboard, Fonts, Paragraph, Styles, and Editing.
• Insert: Pages, Tables, Illustrations, Links, Header & 

Footer, Text, and Symbols.
• Page Layout: Themes, Page Setup, Page Background, 

Paragraph, Arrange 
• References: Table of Contents, Footnote, Citation & 

Bibliography, Captions, Index, and Table of Authorities 
• Mailings: Create, Start Mail Merge, Write & Insert 

Fields, Preview Results, Finish 
• Review: Proofing, Comments, Tracking, Changes, 

Compare, Protect 
• View: Document Views, Show/Hide, Zoom, Window, 

Macros





• Create a New Document 
There are several ways to create new documents, open existing 

documents, and save documents in Word:
I. Click the Microsoft Office Button and Click New or 
II. Press CTRL+N on the keyboard.



• Opening an Existing Document 
I. Click the Microsoft Office Button and Click Open, or 
II. Press CTRL+O on the keyboard, or
III. If you have recently used the document you can click the Microsoft Office Button 

and click the name of the document in the Recent Documents section of the 
window Insert picture of recent docs



• Saving a Document
I. Click the Microsoft Office Button and Click Save or Save As, or 
II. Press CTRL+S on the keyboard, or 
III. Click the File icon on the Quick Access Toolbar.



• Printing Document to a file page
You can print the document. 

I. Print – In print option you can change the number of copies, 
Select page no., choose printer etc before printing.

II. Quick Print – In quick print the document is directly send to the 
printer without making any changes.

III. Print Preview – Preview and make changes to pages before 
printing.



•Most of those frequently used commands are located in the 
Home Tab.
•The Ribbon is located close to the top of the Word window.
•The Ribbon is organized into a set of task‐oriented tabs, and each 
tab on the Ribbon contains groups of commands.
•The Home Tab contains the most frequently used commands in 
Word.



Select the style to apply to paragraphs 

Formatting Features of Ms word:-

Changes the font of the selected text

Changes the size of selected text and numbers 

Makes selected text and numbers bold

Makes selected text and numbers italic

Underlines selected text and numbers



Used for superscript and subscript of the text

It is used to highlight the important text

It is used to change the color of the font.

It is used to draw a line through the middle of the selected text.

It is used for sentence case, Lower case, Upper case, ToGgLe case etc.

It is also used to change the size of the selected text



Make sure the “Home” tab is active and click the “Paragraph Settings” button in the 
lower-right corner of the “Paragraph” section. On the “Paragraph” dialog box, select the 
settings you want to change

Aligns to the left with a ragged right margin.

Centers the selected text. 

Aligns to the right with a ragged left margin.

Aligns the selected text to both the left and right margins 

Makes a numbered list or reverts back to normal.



Add, or remove, bullets in a selected paragraph.

Decreases the indent to the previous tab stop.

Indents the selected paragraph to the next tab stop.

Adds or removes a border around selected text or objects.

It is used to give the spacing between the lines.

It is used to sort the Lines in order to alphabetical or numerical.

Show paragraph marks and other hidden formatting symbol.

Color the background behind the selected text or paragraph.



•Style refers to the format of your paragraph.MS word offers several quick styles 
that you can use.
•These include heading, No spacing, Subtitles, Emphasized text, List paragraph, 
etc. 
•To apply a list go to the “ Home” tab on the ribbon and go to the “Style Group”.
•You will see some style in white boxes. 
•You can scroll through these styles to find one you want to use, or you can click 
the arrow in the “Style” tab to select the one you want. 



• Find and Replace helps you to find words or 
formats in a document and can let 
you replace all instances of a word or format.

• This is particularly handy in long documents. To 
use Find and Replace, use the shortcut Ctrl+H or 
navigate to Editing in the Home tab of the 
ribbon, then choose Find and Replace.



FIND TAB STEPS:

• Find searches for specified text in the active document 
• To find a specified text in the document go to Edit menu choose find 
option or click the find icon ( ) on the toolbar or make use of the 
shortcut key combination Ctrl+F. 
• The Find and Replace dialog box will get displayed.
• Enter the text to be searched in the Find what tab. 
• Clicking the Find Next button the specified text will be located in the 
document.



REPLACE TAB STEPS: 
To find and replace a word or phrase in your document you 
need to :

• Go to Edit section in the Home Tab select “Replace” to open 
the find /replace dialog box.

• Enter the text in the “Find what” box.
• Enter the text in the replace box which you want to replace.
• Note : If you do not enter any character at the “Replace 

box”, the program will delete all the results matching the 
search criteria.



•Many times we need to apply the same formatting effects, like 
font,font size, style, color, border, shading and many more to 
different portions in active document with the help of Format 
Painter facility in MS Word. 
•Format in MS Word is an important tool of Microsoft Word.
•You can use Format Painter to quickly applied copied formatting 
from one place to another place in the active document of MS 
Word.
• If you want to cancel Format paint then you just simply press ESC 
key.



Method 1: Format Painter using the Shortcut Key 
Combination

Step 1. If you want to copy formatting to place and 
apply on another place then first you have to select 
the formatted text or shape which formatting you 
want to copy.

Step 2. To copy the formatting press CTRL+SHIFT+C 
shortcut key combination.

Step 3. Select the target text or shape on which you 
want to paste or apply copied formatting.

Step 4. To paste formatting on target location you have 
to press CTRL+SHIFT+V shortcut key combination.



Method 2: Format Painter using the Mouse

You can also use another method to copy 
formatting from one place to another place using 
the Mouse:

Step 1. Select the formatted text or shape (source 
location) which formatting you want to copy.

Step 2. Now, Click on the Format Painter button 
which is placed in the Home tab >>> Clipboard 
group for copy formatting.

Step 3. Select the target text or shape (target 
location) on which you want to paste formatting.



Figure : Format painter using the mouse



Cut :

• Deleting unnecessary data from a document is called 
cutting.

• In Microsoft Word, you can cut text from one area of a 
document and paste that text anywhere in the 
document.

• After you cut the text, it gets stored in the clipboard.

• If you want to cut any text or word from a document, it 
is advisable to Select the word first.

• To cut, Right Click → Cut.

• The shortcut key is "Ctrl + X".







Copy:

• Copy option can be used when we need to retype 
the same text as it reduces time and effort.

• By using copy option, you can copy the text from 
one location to another.

• Information stored on the clipboard stays there 
until new information is either cut or copied.

• Each time you use cut or copy, you replace the 
old information on the clipboard with the 
information you just cut or copied.

• To copy, Right Click → Copy.

• The shortcut key is "Ctrl + C".







Paste:

• Select your text and then copy it..

• Use mouse to move the cursor to desired 
position to paste the copied text.

• Click paste to insert the copied text in its new 
place.

• You can paste clipboard information as often as 
you like.

• To paste, Right Click → Paste.

• The shortcut key is "Ctrl + V".





• The Insert Tab is right next to the Home Tab in 
Microsoft Word 2007.

• The Insert Tab is used to insert different 
features such as tables, pictures, clip art, 
shapes, charts, page numbers, word art, 
headers, and footers into a document.



• Cover Page :This button can be used to insert a 
pre-formatted cover page for a document. The 
information that is to appear on the page is filled 
in after the page is created. 

• Blank Page :To insert a new blank page for a 
document at the cursor position, click this button. 

• Page Break :Click this button to end a page at the 
current cursor position and start a new page.



Tables :

• This button is used to insert a table into the document. 

• A grid will appear that can be used to create the table. 

• Additional options for creating a table are also available, 
such as drawing a table or using the Quick Tables 
feature.



Picture : 
• To insert a picture from a file on the computer into the document, click 

this button.
• The Insert Picture dialog box will appear.
• This dialog box is used to select the picture that is to be inserted into 

the document.



• In word 2007 , You have the ability to search clip art files 
on your local computer and on Microsoft office online.

• You can Modify that clip art using picture editing tool.

Clip Art : 



Shapes :
• This button is used to insert 

ready-made shapes such as 
circles, squares, arrows, and 
triangles into a document. 

• When the button is clicked, a 
gallery of different shapes will 
appear. 

• To insert a shape, click the 
desired shape and then draw 
the shape in the document.



Smart art :
• Smart Art To insert a Smart Art graphic into the 

document, click this button. 
• Smart Art graphics are objects such as Venn 

diagrams and organizational charts. 
• When the button is clicked, a gallery of different 

categories and shapes will be displayed.



Chart :

• Group/Button Description Chart Use this feature to 
insert a bar, area, or line chart. 

• When this button is clicked the Insert Chart dialog 
box will display.

• In this dialog box, it is possible to specify the type of 
chart.



Inserting a hyperlink
• Open Microsoft Word.
• Type the appropriate text in the Word document.
• With your mouse or keyboard, highlight the text you want to turn 

into a hyperlink. For example, in the picture below, the text 
"ComputerHope website" is highlighted.

• In the menu bar or Ribbon at the top of the Word program window, 
click the Insert tab.

• On the Insert tab, in the Links section, click 
the Hyperlink or Link option.

• In the Insert Hyperlink window, type in the web page address you 
want to set the highlighted text to link to in the Address text field, 
then click OK.



• As you can see in the image below, the highlighted text 
is now a hyperlink, set to the desired web page.



Bookmark :

• Create a bookmark to assign a name to a specific 
point in a document

• A bookmark in Word works like a bookmark you 
might place in a book: it marks a place that you want 
to find again easily. ...



Header :

• To insert text that appears 
at the top of each page of 
the document, click this 
button. A gallery of header 
styles and formats will 
appear.

• Click the heading style that 
is to be applied to insert it 
into the document. 



Footer :

• This button is used to 
insert text that appears at 
the bottom of each page 
of the document. A gallery 
of footer styles and 
formats will appear. 

• Click the footer style that is 
displayed to insert it into 
the document.



•Click Insert > WordArt, and pick the WordArt style you want.
•To insert decorative text into the document, click this button.
• A gallery of different styles of WordArt will display. 
•Click the desired format to create the WordArt image.



Equation : 

• This button is used to 
insert a mathematical 
equation into a 
document. 

• The equation tools ribbon 
will appear when the 
button is clicked. 

• This ribbon is used to 
create the equation. A list 
of common equations is 
also available.



Symbol :

• Click this button to insert a 
symbol such as a copyright or 
trademark into the document.

• It has the symbol that are not 
present in your keyboard like 
copyright symbol, Trademark 
Symbol, Paragraph Marks, and 
Unicode Character.





Introduction :

• The Page Layout Tab holds all the options that 
allow you to arrange your document pages 
just the way you want them.

• You can set margins, apply themes, control of 
page orientation and size, add sections and 
line breaks, display line numbers, and set 
paragraph indentation and lines.



Document Themes :
• On the Page Layout Tab, in 

the Themes Group, click the 
Themes button. A gallery 
opens. 

• Hover your mouse pointer 
over the many themes in the 
Themes gallery. Word 
enables you to preview the 
themes in your document via 
the Live Preview feature.

• To make the change 
permanent, click the theme 
you want to see.



• You can display the "Page Setup" dialog 
box, Margins Tab, by clicking on the page 
layout tab.

1. Margin :
• In the Page Setup group, click the Margins 

button. There you will see a gallery 
showing a number of margin options. Click 
one of the options, and Word applies the 
margins to your document. 

• If none of the gallery’s options are 
satisfactory, click the Custom Margins 
option. The Page Setup dialog box opens 
with the Margins tab displayed. 

• Use the options in the Page Setup Dialog 
Box to adjust the margins to your 
satisfaction. When you have finished, click 
OK.



2. Orientation -
The drop-down contains the 
commands: Portrait and 
Landscape. This provides a 
shortcut to the (Page 
Setup)(Page tab, Orientation).

3. Size - Drop-Down. Lets you 
select from all the different 
available paper sizes. This 
provides a shortcut to the (Page 
Setup)(Page tab, Paper size 
drop-down).

4. Columns - Drop-Down. The 
drop-down contains the 
commands: One, Two, Three, 
Left and Right and the 
command More Columns. 
Provides access to 1,2,3 column 
layouts.

Fig : Size Fig : Columns



5. Breaks - Drop-Down. The drop-down 
contains the commands: Insert Page 
Break, Remove Page Break and Reset 
All Page Breaks.

6. Line Numbers - Drop-Down. The drop-
down contains the commands: None, 
Continuous, Restart Each Page, Restart 
Each Section, Suppress for Current 
Paragraph and Line Numbering 
Options. The Line Numbering Options 
displays the "Page Setup" dialog box 
(Layout tab).

7. Hyphenation - Drop-Down. The drop-
down contains the commands: None, 
Automatic, Manual and Hyphenation 
Options. The Hyphenation Options 
displays the "Hyphenation" dialog box.

Figure : Breaks

Figure : Hyphenation



1. Watermarks :
• In the Page Background group, click the 

Watermark button. A gallery opens 
with a number of standard 
watermarks.

• Click the one you want to use.
• If you don’t want to use any of the 

standard watermarks you can create 
your own by clicking the Custom 
Watermark command. The Print 
Watermark dialog opens. 

• Use the options in that dialog to create 
a text watermark or to select an image 
to use as a picture watermark. 

• When you’ve completed created your 
watermark, click OK.



Page Color :

• On the Ribbon, click on the Design tab

• Locate the Page Background group

• Click on the Page Color button

• Click on a color to set your page background 
color



Page Borders :

• Go to Page Layout>Page Background>Page Borders.

• Make selections for how you want the border to look.

• To adjust the distance between the border and the 
edge of the page, select Options. Make your changes 
and select OK.

• Select OK.



You can quickly display the "Paragraph" dialog box, Indents 
and Spacing tab, by clicking on the Paragraph section of 
Page layout tab.

Indent Left -
• Move in the left side of the Paragraph by a certain amount.
• This can be used to change the left indentation for the 

current selection.

Indent Right -
• Move in the left side of the Paragraph by a certain amount.
• This can be used to change the right indentation for the 

current selection.



Spacing Before -
• This automatically updates to indicate how much 

spacing is defined before the paragraph of the 
current selection. 

• This can be used to change the spacing for the 
current selection.

Spacing After -
• The automatically updates to indicate how much 

spacing is defined after the paragraph of the 
current selection. 

• This can be used to change the spacing for the 
current selection.



Creating Envelops

• Go ahead and open up Word and select the 
“Mailings” tab.

• Next, click the “Envelopes” button.

• The Envelopes and Labels window will appear. 
This is where we’ll enter all of our information. 

• In the “Delivery Address” box (1), enter the 
recipient’s address. The “Return Address” box (2)



Figure : Creating Envelops Figure : options of envelops



Figure : Envelops



Creating Labels:

1) Start Microsoft Word.

2) Click the New Document button.

3) From the Tools menu, select Letters and Mailings, then select Envelopes 
and Labels.

4) Select the Labels tab, click Options, select the type of labels you want to 
create and then click OK.

5) Click New Document.



Figure : Creating Labels



i) In a blank Microsoft Word document, click on the Mailings tab, and in 
the Start Mail Merge group, click Start Mail Merge.
ii) Click Step-by-Step Mail Merge Wizard.

iii) Select your document type. In this we will 
select Letters. Click Next: Starting document.

i)Figure : Select document type



iv) Select the starting document. In this 
example we will use the current (blank) 
document. Select Use the current 
document and then click Next: Select 
recipients.

ii) Figure : Selecting the document 



v) Select recipients. In this Example we will create a new list, so select Type a new 
list and then click Create

vi) Create a list by adding data in the New Address List dialog box and clicking OK.

iii) Figure : Add the Recipients

Figure : Add new Recipients



vii) Click Next: Write your letter.
viii) For adding the address block click on More items

iv) Write Your Letter

Figure : Letter



ix) Click on Preview your letter

v) Figure : Preview your letter Figure : Letter Preview



x) Click Print to print your letters or Edit individual letters to 
further personalize some or all of the letters.

vi) Complete the merge Figure : Merge Options



• Open most Office programs, click the Review tab on the 
ribbon. In Access or InfoPath you can skip this step. In Project 
you'll go to the Project tab.

• Click Spelling or Spelling & Grammar.
• If the program finds spelling mistakes, a dialog box appears 

with the first misspelled word found by the spelling checker.
• After you decide how to resolve the misspelling (ignoring it, 

adding it to the program’s dictionary, or changing it), the 
program moves to the next misspelled word.



Figure : Before Spelling and Grammar Check

Figure : After Spelling and Grammar Check



• Insert a comment
• Select the text you want to comment on, or click 

at the end of the text.
• On the Review tab, click New Comment.
• Type your comment. Word shows your comment 

in a balloon in the document's margin.



•Click the review tab
•Click on the protect document.
•Click on Restrict formatting and editing.
•Check all the checkboxes.
•Click on “Yes,Start enforcing protection.”

Figure : i) Protect Document

Figure : ii) Checkbox selection



Figure : iii) Setting the password

Figure : iv) Removing the Password from the document



The View tab enables you to switch 
between Normal or Master Page, and Single Page or Two-
Page Spread views. This tab also gives you control over 
showing boundaries, guides, rulers, and other layout tools, 
zooming the size of your view of the publication, and 
managing Publisher windows you have open.

Documents View has 5 options:
i) Print Layout
ii) Full Screen Reading
iii) Web layout
iv) Outline
v) Draft



Print Layout:
The screen shot below shows what the Print Layout looks like. This view can be 
used to see what your document will look like when printed. Print Layout is 
also the default view of Microsoft Word 2007.

Full Screen reading:
You can use this one to see the document in reading mode in Microsoft Word 
2007. When using this view, the Ribbon is hidden to maximize your reading 
area.

Web Layout:
Moving on to the Web Layout in Microsoft Word 2007 Document Views. This 
layout is handy especially when you want to see the document in a web 
browser format like the Internet Explorer.

Outline:
The Outline view is probably one of the most useful styles especially if you are 
working on a long document in Microsoft Word 2007. When you switch to this 
layout, all you see is the document divided into different heading levels. You 
can choose the level of detail that you would like to see by controlling the 
Show Level option.

Draft:
The final layout we are going to look at is the Draft view. This is the most 
common format as you will use this one when working on a document. When 
using this layout style you will see the document in a regular editing 
format. The headers and footers are not available when working with the 
Draft view in Microsoft Word 2007.



Everything relating to adjusting the display percentage of the active 
document. There is also a new zoom slider in the bottom right 
corner next to the status bar.

• Zoom - Displays the "Zoom" dialog box. This can also be accessed 
from the status bar by clicking on the view percentage.

• 100% - Adjusts the zoom to 100% of its normal size. Lets you quickly 
return to 100%.

• One Page - Adjust the zoom so an entire page fits in the application 
window.

• Two Pages - Adjust the zoom so two entire pages fit in the 
application window.

• Page Width - Adjust the zoom so the width of the page is the same 
as the width of the application window.



• New Window - Lets you create a new window of the active document.

• Arrange All - Tile all the open windows side by side on the screen. This will also 
maximizes the application / document to a full screen.

• Split - Splits the current window into two parts.

• View Side by Side - Displays two documents side by side so they can be easily 
compared. If you have more than two documents open the "Compare Side by 
Side" dialog box is displayed so you can choose which document to display next to 
the active document. allowing you to scroll multiple windows at the same time.

• Synchronous Scrolling - Toggles the synchronize scrolling of the two documents 
that are displayed side by side. This is only enabled when you are viewing two 
documents side by side.

• Reset Window Position - Resets the windows positions so they take up the same 
amount of space on the screen when two documents are displayed side by side. 
This is only enabled when you are viewing two documents side by side.

• Switch Windows - Drop-Down. Lets you switch between all the currently active 
documents. This displays all the window / documents that are currently open in 
the particular session. Previously these were displayed on the Window menu.





• Microsoft Excel is a spreadsheet, developed by 
Microsoft for Windows, macOS, Android and iOS. 

• Microsoft Excel is a spreadsheet program that is 
used to record and analyze numerical data. 

• Alphabetical letters are usually assigned to 
columns and numbers are usually assigned to 
rows. The point where a column and a row meet 
is called a cell.

• The address of a cell is given by the letter 
representing the column and the number 
representing a row.



Figure : Overview of Microsoft Excel



1. Business Analysis
• The number 1 use of MS Excel in the workplace is to do business 

analysis.
• Business analysis is essentially using collected data to inform 

decision making.
2. People Management
• You may be surprised to learn that one of the top uses of Excel in 

business is to manage people.
• MS Excel is a powerful way to organize information about people, 

whether they are employees, customers, supporters, or training 
attendees.

3. Managing Operations
• Excel is relied on heavily to manage the day-to-day operations of 

many businesses.
4. Mathematical formulas of MS Excel make things easier
• Next best use of MS Excel is that it makes easy for you to solve 

complex mathematical problems in a much simpler way without 
much manual effort. There are so many formulas in MS Excel and by 
using these formulas you can implement lots of operations like 
finding sum, average, etc.



5. Add sophistication to data presentations
• Next use of MS Excel is that it helps you in adding more 

sophistication to your data presentations which means that 
you can improve the data bars, you can highlight any 
specific items that you want to highlight and make your 
data much more presentable easily.

6. Manage expenses
• MS Excel helps in managing expenses. 
• Eg.- Suppose if a doctor is earning around 50,000 per 

month then he will make some expenses as well and if he 
wants to know how much he is exactly spending per month 
then he can do it with the help of MS Excel easily. He can 
write his monthly income as well as expenses in the excel 
tables and then he can get to know that how much he is 
spending and he can thus, control his expenses accordingly.



Create : 
• If you are working in MS Excel and want to begin work in a new Excel 

file, You can easily create a new workbook. To do so , You can use a 
command on the office menu or a keyboard shortcut.

• 1. Click the office button

Figure : The Office menu appears



• 2. Choose New

Figure : The new workbook dialog box appears

• 3. Click the blank workbook icon.

• 4. Click the create button : Excel creates  a new , blank workbook based on the 
default template.



Save : 

1. Click the office button 
and choose save.

2. The save as dialog box 
appears.

3.   Click the save in drop 
down button and select 
the folder in which you 
want to save the file.

4. Type the descriptive 
name for the file in the 
File name box.

5. Click the save button to 
save the file in the 
selected folder.

Figure: The save as dialog box is appears 



Open :
1. Click the office button and choose Open. The Open Dialog box will 

appears.
2. Then Select the Drive and folders in which your file is stored.
3. Or type the name of the file in “File Name” dialog box.
4. Click Open Button to open the file.

Figure : Open dialog box is appears



Print :
•Select the worksheets that you want to print.
•Click File > Print, or press CTRL+P.
•Click the Print button or adjust Settings before you click the Print button.

Figure : Print Dialog Box is Appears



• The home tab ribbon of Microsoft excel is 
made up of 7 groups that is the collection of 
very important command.

• Most of the commands are commonly used in 
manipulating the data 



Cut, Copy, Paste and Format Painter
Cut : (Ctrl + X) – It is for cutting the select section from the document and placing 
It on the clipboard.
Copy : (Ctrl + C) - Copies the selected section and places it on the clipboard.
Paste : (Ctrl + V) – Use this command to paste the content of the clipboard to the 
desired location.
Format Painter : Use this tool to copy formatting from one place
And apply the copied format to another place.

Figure : Various Paste Option



We use this option to change the font style and font-size. We can make it bold, 
italic and underline. Also, this group contains border styles, fill color, font color.
Font : Use this tool to change the Font Style. Clicking on the drop down button 
You will be able to get more fonts.
Font Size : This command is for changing the font size . Highlight the cells you 
want to change the size of and then select the size you want.
Bold(B) : Make the selected text bold.
Italic (I) : Make the selected text to be italicized.
Underline (U) : Underline the selected text . Using the drop down button you 
can get the double underline.
Increase font size : this is another way of increasing the font size.
Decrease font size : Use this shortcut for decreasing the font size.
Borders : Use this command for setting the borders in selected cells.
Fill Color : Color the background of selected text.
Font Color : Change the text color.



1. Top Align : This command align text to the top of the cell.
2. Middle Align : this tool will align text such that it will be centered towards the top and 
bottom of the cell.
3. Bottom Align : Use this command to align text to the bottom of the cell.
4. Align text Left : this tool lets you align text to the left of the cell.
5. Align text Right : this tool lets you align text to the right of the cell.
6. Center : This Command is for centering text in the cell.
7. Decrease Indent : This tool decrease the margin between the cell border and the text in 
the cell.
8. Increase Indent : This tool increase the margin between the cell border and the text in 
the cell.
9. Orientation : Use this command to rotate selected text to a diagonal or vertical angle 
orientation. This is often use for labeling narrow column.
10. Wrap text : This command makes all content visible within a cell by displaying it on 
multiple lines.
11. Merge and center : This command is used to joined the selected cells into one larger 
cell and centers the contents in a new cell.



• General : This command Helps you to choose how 
the values in a cell are displayed. 

• Accounting number format : Use this command 
to set the alternate currency format you want to 
use for the selected cell. Open drop – down 
button for more currencies.

• Percentage Style : Use this command to apply the 
percentage format to selected cells.

• Comma Style : This displays the content of the cell 
with a thousand separator.

• Increase Decimal : It shows more decimal places.

• Decrease Decimal : Show less precise value by 
showing fewer decimal places.

Figure : General

Figure : Accounting Number format



• Conditional Formatting :
This button is used to select different formatting for cells based on particular 
criteria. 
It is possible to highlight interesting cells, emphasize unusual values, and 
visualize data using Data Bars, Color Scales, and Icon sets.
• Format as Table :
Click this button to quickly format a selected range of cells as a table using a 
gallery of table styles. 
• Cell Styles : 
This button is used to apply predefined formatting to a single cell. 
A gallery of styles will appear. 
Move the mouse pointer over the style to see a Live Preview of the style.



1.   Insert :
•To insert cells, sheet rows, or sheet columns, click this button. A list of 
possible options will appear. 
•Click the option that is to be applied to the worksheet. 
2.   Delete : 
•This button is used to delete cells, sheet rows, or sheet columns from a 
worksheet. 
•If the arrow is clicked, a list of available options will appear.
3.   Format :
•Click this button to change the row or column height and width, to 
organize worksheets in the workbook, to protect the document, or to 
hide a sheet in the workbook. 
•A list of available options will appear when the arrow is clicked.



1. Auto Sum :
• To display the sum of selected cells directly to the right or below the 

selection, click this button.
• Where the sum is displayed will depend on whether the selection range is a 

column or row.
2. Fill :
• Click this button to continue a pattern of values in a selected range of cells. 
3. Clear:
• This button is used to clear the contents from the cells in the selected 

range. 
• It can also be used to clear the formatting or comments associated with the 

cell selection. 
4. Sort and Filter :
• To sort the data in a selected range of cells, click this button.
• It is also possible to filter out specific data in the selected cells.
5. Find and Select :
• Click this button to locate specific data in a worksheet or a range of cells.
• It is also possible to replace data within the worksheet or range of cells



• We use Insert tab to insert the picture, charts, 
filter, hyperlink etc. We use this option to insert 
the objects in Excel. To open the insert tab, press 
shortcut keys Alt+N.

• The insert tab have following groups:
1. Tables
2. Illustrations
3. Charts
4. Links
5. Text



Pivot Table : 
• A pivot table is used to display the Excel worksheet table into another 

Summarize form.

• A pivot table terms all the data into small, concise report that tells exactly 
what user need to know.

Steps :
1. Go to insert menu and select the pivot table option.

2. A dialog box appears which ask for range, click on the text box  and then 
select the data source from the excel sheets with column heading.

3. Now select the place that is new worksheet or existing worksheet.

4. Select anyone option from two options given as below.

i) New worksheet : To insert new table I new worksheet.

ii) Existing worksheet : To insert pivot table in existing file in which the data 
source is present.

5.      Then click on “OK” Button. It will insert pivot table with the selected data 
source.



How to create pivot table?

• Insert the data :

• Click on Pivot table :



•Dialog box appears where you can select the area.

•Then the  Table is appears 



Table : 

• This button is used to insert a table into the 
worksheet.

• Tables make it easy to analyze and sort data.

Figure : Table Formatting Options 

Figure : Tables



Illustration: - We use this option to insert the Pictures, Online Pictures, 
Shapes, SmartArt and Screenshot. It means if we want to insert any 
image, we can use Illustration feature.
Picture :-
•To insert a picture that has been stored on the computer, click this 
button. 
•When the button is clicked, the Insert Picture dialog box will appear. 
•This dialog box is used to locate the picture that is to be inserted into the 
worksheet.
Shapes :-
•Shapes are objects, such as rectangles, circles, lines, and arrows. To 
insert a shape into the worksheet, click this button. 
•When the button is clicked, a gallery of different shapes is displayed. 



Smart Art :-

• To insert objects such as organization 
charts, click this button. A gallery of 
different objects is displayed. 

• This gallery is divided into categories, 
such as list, process, cycle, hierarchy, 
relationship, matrix, or pyramid.

Clip Art : 

• In excel 2007 , You have the ability to 
search clip art files on your local 
computer and on Microsoft office 
online.

• You can Modify that clip art using 
picture editing tool.

Figure : ClipArt



Charts: -
• Charts is very important and useful function in Excel. 
In excel, we have different and good numbers of 
readymade chart options. We have multiple types of 
different charts in Excel Column, Bar, Radar, Line, Area, 
Combo, Pie and Bubbles chart. 
• A chart is a visual representative of data in both 
columns and rows. 
• Charts are usually used to analyze trends and patterns 
in data sets.

Types of Charts :
1) Column chart: - It is made up of horizontal or vertical 
column which represents the comparison of two or 
more things.

Figure : Column chart



2) Line Chart : 
• Line chart is represented through 

different data series and it represented 
through different color of shading.

• It shows continuous change over the 
line.

3) Bar chart:-
• A bar chart is a chart that shows 

information about two or more 
discrete objects, events, locations or 
groups of people, etc.

4) Pie Chart : 
• It is a circular graph where the pieces 

of the pie are used to represent a 
percent (%)of a whole. 

• These charts denote use horizontal 
and vertical axes to plot charts.

• The circle of the pie represents 100%, 
The size of each slice show which part 
of 100% it represents.

Fig : Line Chart

Fig : Pie Chart

Fig : Bar Chart



5) Area chart:-

• It emphasizes the magnitude of 
change over time by displaying 
the sum of plotted values, an 
area chart shows the 
relationship of parts to a 
whole. 

• It combines some of the 
characteristics of a line chart 
with a bar chart.

6)  Other chart:-

• Excel offers other chart types, 
such as Stock, Surface, 
Doughnut, Bubble, and Radar. 

• To locate a menu of all 
available chart types in newer 
Excel versions, begin to insert 
any chart type and click All 
Chart Types …

Figure :Area Chart

Figure : Other Chart



Steps to create a chart in MS Excel:

1. Open Excel

2. Enter the sample data

3. Select the data you want to represent in 
graph

4. Click on INSERT tab from the ribbon

5. Click on the Column chart drop down button

6. Select the chart type you want



Example :

Figure : Data

Figure : Column Chart

Figure : Line chart Figure : Pie Chart



Example :

Figure : Area Chart

Figure : Bar Chart



1.   Text Box
• This button is used to insert a textbox into the worksheet. Text boxes 

can be used to highlight an item in a chart or within the worksheet. 
• Textboxes can be inserted and/or positioned anywhere within the 

worksheet page. 
2.   Header and Footer :
• To insert a header and/or footer into a worksheet, click this button.
• The header or footer area of the worksheet will display when this 

button is clicked. The header or footer can be inserted directly into 
this area. 

3.   Word Art :
• Click this button to insert a Word Art object into the worksheet or 

chart. A gallery of Word Art styles will appear. 
• Select any of the styles to display the text box. The text box is where 

the text for the Word Art can be specified. 



4.   Signature Line :
• Use this button to insert a signature 

line into the worksheet. 
• The signature line specifies the 

individual who is to sign the file in 
order to access it. 

5.   Object:  
• To insert an embedded object, such 

as documents from other programs, 
click this button. A dialog box will 
display from which a list of options 
can be chosen. 

• Click the Create from File option to 
insert a designated file.

6. Symbol :
• This button is used to insert a 

symbol, such as a copyright 
symbol, into the worksheet. 

• When the button is clicked, a 
gallery of different symbols will 
appear

Figure : Symbol



In Page Layout option, we have various commands which 
we use to prepare the workbook for printing and exporting 
to PDF format. Through this command, we can adjust the 
page in the way we want to see after printing.
The Page Layout Tab is divided into the following groups:

1. Themes Group
2. Page Setup Group
3. Scale to Fit Group
4. Sheet Options Group
5. Arrange Group

Figure : Page Layout Ribbon



a) Themes: -
• This option is used to change the theme 

color of workbook by just click of a 
button. 

• Each theme has 12 colors, two fonts 
(heading and body), SmartArt and the 
effects for shape. 

Figure : Themes Group



Margins:
•The first Page Setup option is Margins, 
which lets you control the white space in 
your document.
• We would like to switch margins in the 
worksheet from Normal to Narrow so we 
can see more of data when we print this 
file.
•Go ahead and click on Margins 
command and then select Narrow from 
the drop down menu. Figure : Margins Tab



Orientation - Drop-
Down. Lets you switch 
between Portrait and 
Landscape.
Size - Drop-Down. Lets 
you select from all the 
different available paper 
sizes. The More Paper 
Sizes displays the "Page 
Setup" dialog box, Page 
tab.

Figure : Orientation Figure : Size



• Print Area - Drop-Down. This drop-down contains the 
commands: Set Print Area and Clear Print Area.

• The default print area for Excel is ALL of the data. 
Unless you have set up your pages this can make for a 
very confusing pile of paper, especially if you have lots 
of columns.

• Another way is to set the print area. To do this highlight 
the data you want to print, click on the page layout, 
print area, set print area.

Figure : Selecting the print area

Figure : Previewing the print area



• Breaks - Drop-Down. This drop-down contains 
the commands: Insert Page Break, Remove 
Page Break and Reset All Page Breaks.

• Background - Displays the "Sheet Background" 
dialog box to let you add a background image 
to the back of a worksheet. This caption 
changes to 'Delete Background' if an image is 
assigned to the active worksheet.



• Scale to Fit: -This option helps to fit the page 
for printing by shrinking or enlarging its size to 
better fit the pages. We can use Scale to fit to 
adjust the width and height by describing the 
scale %age.

• If your worksheet has a lot of columns, you can 
use the Scale to Fit options to reduce the size 
of the worksheet to better fit the printed page.



Mathematical Function :

To perform basic mathematical operations 
such as addition, subtraction, or 
multiplication; combine numbers; and 
produce numeric results, use the following 
arithmetic operators.



1. Sum : This Function is used to perform the addition 
of two or multiple operands.

2. Average : In order to take the average of more than 
one range using a single function, first start the = 
AVERAGE function. After adding your first range 
press "," (comma) and then select the second range 
of values, end the function with a parenthesis 
(bracket) and press enter.

3.   MIN/MAX

I. MIN - Will return the smallest number found in a set 
of values.

II. MAX - Will return the highest number found in a set 
of values.

4.    COUNT - Counts the number of cells in a range than 
contain numbers



Example :



Logical Function
1.   If : The IF function checks whether a condition is met, and 

returns one value if true and another value if false.

2.   And : The AND Function returns TRUE if all conditions are 
true and returns FALSE if any of the conditions are false.



Logical Function
3.   Or : The OR function returns TRUE if any of the conditions are 

TRUE and returns FALSE if all conditions are false.

4.    Not :

• The NOT function changes TRUE to FALSE, and FALSE to TRUE.

• For example, take a look at the NOT function in cell D2 below.



Math and Trig Functions in ms Excel :
1.  SIN/COS/TAN function : The Excel 

function returns the sine/cose/tane
of angle given in radians. 

• To supply an angle to SIN/COS/TAN 
in degrees, multiply the angle by 
PI()/180 or use the Radians function 
to convert to radians. 



2. Ceiling and Floor Function :

Ceiling Function : The Excel CEILING function is 
categorized under Math and Trigonometry 
functions. The function will return a number that is 
rounded up to a supplied number that is away from 
zero to the nearest multiple of a given number.

• Formula :

• =CEILING(number, significance)



• Floor Function : The Microsoft Excel FLOOR function 
returns a number rounded down based on a multiple 
of significance.

• The FLOOR function is a built-in function in Excel that 
is categorized as a Math/Trig Function.

• Formula :

• FLOOR( number, significance )



3. MOD function : 
• The MOD function is categorized under Excel Math 

and Trigonometry functions. The function helps find a 
remainder after a number (dividend) is divided by 
another number (divisor).

• Formula
• =MOD(number,divisor)
4. FACT function : The Microsoft Excel FACT function 

returns the factorial of a number.
• Formula 
• =FACT( number )
5. LOG function : Returns the logarithm of a number to 

the base you specify.
• Formula :
• =LOG(number, [base])



It is mainly used import data from a simple external 
database powered by Microsoft Access database. We 
will import the products table into excel.

STEPS :

1. Create a record in Ms access data base.



2.   Open a new workbook

3.   Click on the Data tab

4. Click on from Access button as shown below

5. The following dialog box will appear.



• Browse to the database that you was create in ms 
access and

• Click on Open button

• Click on OK button

• You will get the following data



Sort data :

• For a quick sort, click the arrow below the Sort & Filtering icon in 
the Editing group of the Home ribbon and choose the Sort A to Z 
/ Z to A icons in the Sort & Filter group of the Data ribbon. 

• In Excel , these are labeled Sort Smallest to Largest and vice 
versa.

• For a more complex sort, go to the Data ribbon, click the arrow 
below the Sort & Filter icon in the sort and filter group and 
choose Custom Sort.



• Under Column, choose the first column that you would like 
to sort. If you want to sort multiple columns, click the Add 
Level button.

• Under Sort On, choose how you would like to sort. 
• Under Order, choose A to Z (ascending), Z to A (descending), 

or Custom List.
• Click OK to perform the sort.



Filter data :

• Go to the Data ribbon, and then click Filter in 
the Sort & Filter group.

• Check the box next to the criteria you wish to 
match and click OK. Click on the arrow next to 
another heading to further filter the data.

To clear the filter, choose one of these options:

• Go to the Data ribbon and click the Clear icon 
in the Sort & Filter group.



• MS Excel data validation feature allows you to 
set up certain rules that dictate what can be 
entered into a cell. For example, you may 
want to limit data entry in a particular cell to 
whole numbers between 0 and 10. If the user 
makes an invalid entry, you can display a 
custom message as shown below.

• Click on the data tab and then click on the 
validation.



•The dialog box appears set the validation as your need.

•Then if you entered the value that is not under the set 
range it will give you a message .



Settings Tab :
• Any Value − Selecting this option removes any existing data validation.

• Whole Number − The user must enter a whole number.For example, you can specify 
that the entry must be a whole number greater than or equal to 50.

• Decimal − The user must enter a number. For example, you can specify that the entry 
must be greater than or equal to 10 and less than or equal to 20.

• List − The user must choose from a list of entries you provide. You will create drop-
down list with this validation. You have to give input ranges then those values will 
appear in the drop-down.

• Date − The user must enter a date. You specify a valid date range from choices in the 
Data drop-down list. For example, you can specify that the entered data must be 
greater than or equal to January 1, 2013, and less than or equal to December 31, 
2013.

• Time − The user must enter a time. You specify a valid time range from choices in the 
Data drop-down list. For example, you can specify that the entered data must be 
later than 12:00 p.m.

• Text Length − The length of the data (number of characters) is limited. You specify a 
valid length by using the Data drop-down list. For example, you can specify that the 
length of the entered data be 1 (a single alphanumeric character).

• Custom − To use this option, you must supply a logical formula that determines the 
validity of the user’s entry (a logical formula returns either TRUE or FALSE).



Input Message Tab
You can set the input help message with this tab. Fill the title and Input message 
of the Input message tab and the input message will appear when the cell is 
selected.



Error Alert Tab:
You can specify an error message with this tab. Fill the 
title and error message. Select the style of the error as 
stop, warning or Information as per you need.



• Group is a tool in excel with which we can group 
two or more rows or columns together, it helps 
to represent the group of rows or columns 
together, also it gives us an option of minimize 
and maximize the group.

• minimizing the group hides those rows or 
columns grouped together and maximizing 
shows the group, Group option is available in the 
data tab under the outline section.



• Enter the records which you want to group.



• Select the rows or columns you wish to group.

• On the Data tab, in the Outline group, click 
the Group command.

• Then you can see the groups as follows





• To ungroup data in a list in Excel:

• Select the rows or columns you wish to 
ungroup.

• On the Data tab, in the Outline group, click 
the Ungroup command.



• Goal Seek is Excel's built-in What-If Analysis 
tool that shows how one value in a formula 
impacts another. 

• More precisely, it determines what value you 
should enter in an input cell to get the desired 
result in a formula cell.                                                                                                    



Steps :

• On the Data tab, in the Data Tools group, 
click What-If Analysis, and then click Goal 
Seek.

• In the Set cell box, enter the reference for the 
cell that contains the formula that you want to 
resolve.

• In the To value box, type the formula result 
that you want.

• In the By changing cell box, enter the 
reference for the cell that contains the value 
that you want to adjust.



Step 1 :

Step 2 : Click on what-if-analysis and then click on goal seek following dialog box will 
appear

Step 3 :



• To prevent other users from viewing hidden 
worksheets, adding, moving, deleting, or 
hiding worksheets, and renaming worksheets, 
you can protect the structure of your Excel 
worksheet with a password.

• To protect the structure of your worksheet, 
follow these steps:

• Click Review > Protect Worksheet.



• Enter a password in the Password box.

• Select OK, re-enter the password to confirm it, 
and then select OK again.



• To prevent other users from viewing hidden 
worksheets, adding, moving, deleting, or hiding 
worksheets, and renaming worksheets, you can 
protect the structure of your Excel workbook with a 
password.

• To protect the structure of your workbook, follow 
these steps:

1. Click Review > Protect Workbook>Protect Structure and 
windows



2. Enter a password in the Password box.

3.   Select OK, re-enter the password to confirm 
it, and then select OK again.



• Click the Review tab.

• Click Share Workbook in 
the Changes group.

• The Share Workbook dialog 
box will appear, and you 
select the Allow changes by 
more than one user at the 
same time. This also allows 
workbook merging check box 
on the Editing tab.



• Optionally, switch to the Advanced tab, select 
the desired settings for tracking changes, and 
click OK.

• Save you Excel file to a network location where 
other people can access it (the fastest way is by 
using the Ctrl + S shortcut).



• Page Breaks : View a preview of where page will 
break when this document is printed

• Page layout : View the document as it will appears 
on the printed page.

• Freezing panes : keep a portion of the sheet visible 
while the rest of the sheet scrolls.

• Split : Split the window into multiple resizable 
panes containing views of your worksheet.
You can use this features to view multiple distant 
parts of your worksheet at once.

• Hide : Hide the current window so that it can not 
be seen.
to bring the window back , click on the unhide 
button.





• MS PowerPoint is a program that is included in the 
Microsoft Office suite. It is used to make presentations 
for personal and professional purposes.

• Microsoft PowerPoint is a powerful presentation 
software developed by Microsoft. It is a standard 
component of the company's Microsoft Office suite 
software, and is bundled together with Word, Excel 
and other Office productivity tools.

• Microsoft PowerPoint is a software application that is 
particularly used to present data and information by 
using text, diagrams with animation, images, and 
transitional effects, etc in the form of slides. It helps 
people to better understand the idea or topic in front 
of the audience practically and easily.



Use of MS Power Point :

1. Power Point in education

• Teachers can use PowerPoint to teach subjects lessons and 
chapters of any book.

• It gives the opportunity to the teacher to cover a topic in the 
different t slides. And in each slide, they can manage, 
highlight, mention, and teach important points that are 
essential to cover on that topic. 

• On the contrary, students can create their own presentations 
for self-learning or can create for teachers to show them.

2. PowerPoint in business:

• PowerPoint helps people in business to create a plan, 
structure related to the business or organization. 

• In the case of the training team, you create and showcase the 
methods with the help of diagrams, images, and circles.



3. PowerPoint for job seekers

• Through PowerPoint, job seekers can create digital 
resumes or multimedia resumes and it will become 
a unique way of presenting skills and knowledge in 
front of interviewers.

4. Use PowerPoint to Make Tutorials

• For the purpose of training or educational 
contexts, PowerPoint can be easily used to create 
worksheets and tutorials. 

5. Use PowerPoint as a Photo Slide Show

• By using PowerPoint, you can create photo slide 
shows or digital album for personal promotional 
uses. For instance, you can create a touching 
tribute to your family members.



1. Slides : Slides are the individual pages of your presentation. Slides 
can have titles, text, graphs, drawn object, shapes, ClipArt, drawn 
art etc.

2. Handouts : These are the printed copies of our presentations. They 
can be one per page or reduced.

You can also print your slides as handouts with two, three, four, six 
or nine slides on a page that your audience can use for future 
reference.

3.    Speaker’s Notes : These provide the presenter with a page which 
corresponds to each slide and contain a small image of the slide 
along with additional notes. These are the reminder notes.

4. Objects : These are the individual elements which make up the 
presentation. These objects can be text, clipart, pictures, charts or 
other types of graphics .

5. Place holder : These let us to quickly add the type of element we 
are likely to put in a particular portion of the slide.





The ribbon consists three areas :
1. Tabs : theses are at the top of the ribbon eg : Home, 

Design, Animations etc.
2. Groups : Each tab has its own set of groups – eg : The 

home tab contains the Clipboard slides, Font, 
Paragraphs, Drawing and editing group etc.

3. Commands : These are the buttons, Boxes or menus 
relative to each group for eg : the alignment and bullets 
and numbering, buttons are in paragraph group. While 
find and replace are in editing group.



Figure : Office button



• New: To create a new presentation

• Open: To open an existing presentation

• Save: To save changes made in the open 
presentation

• Save As: To save the presentation with a specific 
name to a preferred location in the computer

• Print: To print the hard copy of the open 
presentation

• Prepare: To prepare the presentation for distribution

• Send: To send the copy of the presentation to others

• Publish: To distribute the presentation to others

• Close: To close the open presentation



STEPS : 

Step1: Open Microsoft Power point. 

Step2: Go to File at the top of the screen and 
click New. A box that says “Blank/New 
Presentation” should appear on the right side 
of your screen. 

Step 3: Slide Title/ Subtitle Give any title and 
subtitle to your ppt on slide1.



Step 4: As per your choice apply different formatting options to 
format the text and pictures.

Step 5: Add new slide by clicking on new slide on formatting bar or by 
right clicking and selecting new slide option.



Step 1 : click on the office button

Step 2 : click on the save button

Step 3 : the following dialog box will appear.

Step 4 : Give the name to your presentation.

Step 5 : click on OK Button

Figure : Step 1, 2

Figure : Step 3,4,5



• pptx file extension is a Microsoft 
PowerPoint Open XML (PPTX) file created by 
Microsoft PowerPoint.

Steps for opening the Presentation :

STEPS : 

Step1: Open Microsoft Power point. 

Step2: Go to File at the top of the screen and 
click Open. A box that says “Select the folder” 
should appear on the right side of your 
screen. 

Step 3: Select the folder than click on “Open”.



Figure : Click on Open Figure : Select the folder than click on Open



In PowerPoint, you can print your slides, your 
speaker notes.

Print your presentation :

• Select File > Print.

• For Printer, select the printer you want to 
print to.

• Choose a print layout: Under Settings,Click on 
Print then click on “Print Preview” then click 
on “Handouts”.

• From handouts select how many slides you 
want in one page.



Example : Here we select 2 Slides Per page



1.New Slide -

• Click this button to insert a new slide into the 
presentation. 

• The slide will be inserted after the current slide with 
the same format as the current slide. 

• Clicking the arrow will display a gallery of different 
slide layouts. Click any of the slide layouts to insert a 
new slide into the presentation.



Figure : Adding New Slide



2. Layouts :

• Layout When this button is clicked, a gallery of 
different slide layouts will appear. 

• Click one of the layouts to apply it to the current 
slide; the slide where the insertion point is located.

Figure : Different Layout Designs



3. Reset : 

• This button is used to reset the slide position, 
size, and formatting to its default value.

• Reset the position, size and formatting of the 
slide placeholders to their default settings.

4. Delete :

• Removes the slides currently selected.



1. Text Direction :
• To change the orientation of text to vertical or stacked, click 

this button. 

• It is also possible to rotate the text using this button.



2. Align Text :

This button is used to specify 
how text is aligned vertically in 
the text box. The default 
options are top, bottom, and 
middle.

3. Convert to SmartArt :
• Convert text to the smart 

graphic to visually communicate 
information.

• Smart Graphics range from 
graphical lists and process 
diagram to more complex 
graphics, such as Venn diagram 
and organization charts.

Figure : Align text

Figure : Convert to Smart Art



• Drawing
This area allows you to draw shapes, arrange them, 
and style them:

• On the left there are Autoshapes, starting 
with Recently Used Shapes. This can include a Text 
Box, which is counted as a Basic Shape. 

• Notice that there are three buttons on the right side 
of the Autoshapes box. The top two will scroll up and 
down the list of different shape types. The bottom 
button will show the whole list of shapes.



Figure : Different types of available shapes



• Next, you can arrange the 
Shapes

• Choose Quick Styles ("presets") 
for decorating the shapes:

• And then, finally, on the far 
right, you can use one of the 
three buttons for:

• Shape Fill: choose a fill color 
(background color) for a shape;

• Shape Outline: choose a color 
and style for the shape's outline

• Shape Effects: choose between 
the many special and 3-D 
effects: Shadow, Reflection, 
Glow, Soft edges, Bevel, or 3-D 
Rotation. There are also presets 
for you to choose from.

Figure : Arrange Shapes

Figure : Quick Styles



Introduction :

• The second tab in the Ribbon is 
the Insert tab. This contains the basic set 
of Objects which you can insert into a slide.

• The Insert Tab is used to insert different 
features such as tables, pictures, clip art, 
shapes, charts, page numbers, word art, or 
headers, and footers into a presentation



1. Tables :

• This button is used to insert a table into a slide. A list will 
appear with a grid that can be used to create the table.

• Additional options for creating a table, such as drawing a 
table, are also listed.

• If you click on the Tables button, this menu will appear:

Figure : Inserting table



• You can select the number of columns and rows by 
dragging the mouse over the grid. Notice that while 
you drag the mouse, the table dynamically draws 
itself in the slide, giving you a preview of what the 
table will look like when you decide on a size:



1. Picture : Pictures To insert a picture from a file into 
the document, click this button. The Insert Picture 
dialog box will appear. This dialog box is used to 
select the picture.



2. Clip Art : Displays the Clip Art Task Pane.

To use clip art’s gallery , Follow these steps:

❑ Select desired slide.

❑Click on “Insert menu”. A Ribbon is open.

❑ Point to the “Clip Art” Command in the 
illustrations group.

❑Click on clip art Option .”Insert clip art ” 
dialog box will appear.

❑ Search the clip art that you want to 
insert and click on the image of the clip 
art .

.
Figure : Clip Art



3. Photo Album : To create a presentation based on a 
set of pictures, click this button. Options can be set 
for how the pictures display on the slide. Also, 
captions may be added to each picture

Steps : 
•Click on insert tab.
•Click on “Photo album” Present in In illustration Group, The 
drop down will appear.
•Click on New Photo album.
•The dialog box will appear for selecting and inserting the 
images.
•Then click on create button.



Figure : Inserting the Picture

Figure : Selecting the image



4. Shapes: 

• add any of more than 100 pre-made 
shapes.

• This button is used to insert different 
shapes into a slide. 

• A gallery of different kinds of shapes 
will appear when the button is 
clicked. To insert a shape, click the 
desired shape and then draw the 
shape in the slide..

Figure : different Shapes



5. Smart Art  : 

• To insert a Smart Art graphic into a slide, click this button. 
Smart Art graphics are objects such as Venn diagrams and 
organizational charts. 

• When the button is clicked, a gallery of different categories 
and shapes will be display.

• SmartArt is a system which allows you to quickly crate visual 
charts. Click on this, and you get a dialog box:

Figure : Choosing the SmartArt Graphic



6. Chart :

• Click this button to display the Insert Chart dialog 
box. This will display a gallery of different types of 
charts that can be created in a Power Point 
Presentation.

Figure : Inserting the chart



How to Insert Chart :

• Select the Insert tab

• In Illustrations group click on Chart command

• An Insert Chart dialogue box appears

• Select the desired Chart style and click Ok

• Chart will be added to slide and an Excel worksheet 
appears on right side of the slide



How to Enter Chart Data :

• We can't enter data directly in charts. To enter data in chart we 
have to type it in excel spreadsheet that appears when you add 
Chart or click Edit Chart option.

• The data that you enter in spreadsheet automatically appears 
in the Chart. Select the cell of spreadsheet and type the data it 
will appear in the slide. Repeat the process to enter the entire 
data.



1. Hyperlink : 

• With the help of this option, we can link any other 
file in our file. Which will open when clicked with the 
mouse during the slide show.

• To insert a link to items such as a Web page, another 
document, or an email address, click this button. The 
Hyperlink dialog box will display where the link can 
be specified. It is also possible to create a new 
document, worksheet, or presentation while creating 
a link to the item 



Steps To create a hyperlink : 

• Enter some text which you want to make hyperlink.

• Select the text and then click on “Hyperlink button” 
in Links Group. The dialog box will appear.

• Select the file that you want to attach. and then click 
on “OK”. 

Figure : Selecting the file to attach in hyperlink



2. Action : 

• When some type of actions such as 
creating a hyperlink to an object or 
inserting a sound is to be specified, 
click this button. 

• The Action Settings dialog box will 
appear. In this dialog box, it is possible 
to create hyperlinks to other files, 
other PowerPoint presentations, to 
the first or last slide in the 
presentation, or too many other areas. 

• It is also possible to apply a sound to 
the selected object.

• With this option, you select a shape 
and apply the action to the shape that 
the action shows during the slide show 
such as next slide, previous slide, end 
show, etc.

Figure : Setting the action of the object 



1. Text Box :

• Inserts a textbox that can be positioned 
anywhere on the page.

• Text boxes are used to highlight text within a 
presentation. 

• With this option, a box can be created in the 
slide in which text can be written.

Figure :Inserting text box



2. Word Art :

• Insert decorative text in your Document.

• The drop-down gives you a choice of Word Art styles to insert.

• When the button is clicked, a gallery of Word Art styles will be 
displayed. Click one of the styles to apply it to the Text.

Figure : Word Art Styles



3. Object :

• Use this button to insert an object such as an Excel 
Worksheet or an Excel Chart into the presentation.

• By this option we can add other program's file like 
Word, Excel, PowerPoint, Photoshop etc. Or we can 
Insert already created file of other program then MS 
PowerPoint.

Figure : Selecting the Object 



Introduction : 
❑This tab is used to apply a design to a PowerPoint 
presentation.
❑It is also possible to make changes to the slide 
size, slide background, and other design attributes.



1. Page Setup : 

• This allows you to change basic page elements including slide sizes, 
orientation, and slide numbering.

• It also Provides the features of changing the height and width of the 
slide.

• Click on the Page Setup command the following dialog box will 
appear for all the settings :

Figure : Page Setup



2. Slide Orientation :

• The second button simply allows you to change the 
slide orientation quickly--from horizontal to vertical 
("landscape" to "portrait").

Figure : Slide Orientation



• Here you can choose the overall appearance for your entire slide show.

• Themes are an easy way to design a whole slide show. Every slide in the 
presentation will change to match the background, font, colors, and effects 
chosen for each theme.

• The good point about themes is that they are easy and quick and make your 
presentation look nice.

• Move the mouse pointer over each of the designs to see a Live Preview. Click 
the design to apply it to the presentation. 

• To access additional themes, click the arrows at the end of the Styles Gallery. 
To display all the designs, click the More button in the lower right corner of 
the gallery.



• Clicking on "Background styles" lets you choose 
quickly from the styles below:

• If you click on "Format Background," you can choose 
far more detail about the slide background.

Figure : Different Background Styles



Introduction : 
• Animation can help make a PowerPoint presentation 

more dynamic, and help make information more 
memorable.

• This tab can be used to set animations for the 
PowerPoint presentation. Animations determine how 
the bullets, pictures, images, and other objects will 
enter the slide during a presentation. 



• There are several animation effects you 
can choose from, and they are organized 
into four types.

• Steps :

i) In Normal view, display the slide that has 
the text or objects we want to animate.

ii) Select  the object we want to animate.

iii) On the slide show menu , click custom 
animations.

iv) It Gives us various option present in add 
effect button.

v) Choose the effect from the drop down 
that you want.

Figure : Custom Animations



1. Entrance: These control how the object enters the slide. For 
example, with the Bounce animation the object will "fall" 
onto the slide and then bounce several times.

Figure : Types of animations

Figure : Entrance Effects



2. Emphasis: These animations occur while the object is on the 
slide, often triggered by a mouse click. For example, you can 
set an object to spin when you click the mouse.

3. Exit: These control how the object exits the slide. For example, 
with the Fade animation the object will simply fade away.

Figure : Emphasis Effects

Figure : Exit Effects 



Add transition between slides :

• Select the slide to which you want to apply the effect

• Select the Animation tab

• In Transition to This Slide group you will see the 
transition effects

• Click the drop-down arrow to see menu of transition 
effects

• Select the desired transition effect

• Click Apply To All to apply the effect to all slides



Figure : Different Slide transition



ii) Setting transition speed and sound :

How to Set Slide Transition Sound

• Select the slide to which you want to add the transition sound

• Select the Animation tab

• In Transition to This Slide group click the drop-down arrow 
next to Transition Sound option

• A list of different transition sounds appears

• Select the desired transition sound

• Click Apply To All to apply the effect to all slides



How to Set Slide Transition Speed :

• Select the slide

• Select the Animation tab

• In Transition to This Slide group click the drop-down arrow 
next to Transition Speed option

• It will display three options for transition speed

• Select the desired transition speed

• Click Apply To All to apply the same transition speed to all 
slides



• Select the slide
• Select the Animations tab
• In Transition to This Slide group locate the Advance 

Slide section
• It shows two options; On Mouse Click and 

Automatically After
• Enter the desired time for the selected slide in 

Automatically After option
• Select the next slide and choose the desired time
• Click Apply To All If you want to apply the same timing 

to all slides



• This tab provides options for presenting the 
Slide Show to the audience. Narration for the 
show can be recorded. 

• Decisions can be made as to where to start 
the presentation. In addition, custom shows 
can be created.

• This contains tools that control how the slide 
show is presented.



i) From Beginning (F5) : Click this button to start the slide 
show at the first slide. This will start the show at the 
beginning.

ii) From Current Slide (Shift+F5) : This option is used to start 
the presentation from the active slide in the slideshow.

iii) Custom Slide Show : Using this option we can select 
some slides from the presentation and run it 
separately. Using this option, we select the desired slide 
from the presentation and make a set and save it by 
giving a name. Which can be run separately.



i) Set Up Slide Show : In this option, we do some setup related to slides 
such as which slide to show form the presentation - Like All, some 
special series or custom slides.

ii) Hide Slide : With this option we hide the active slide. ie the hidden 
slide will not be visible in the slideshow.

iii) Record Narration : To record a narration to go with the slides in the 
presentation, click this button. The Record Narration dialog box will 
display where the options for recording can be set

iv) Rehearse Timings : On clicking this option, the timer runs along with 
the slideshow, after the slideshow finished, it tells how much time the 
presentation has been taken. So you can rehearse with the 
presentation from the timer.

v) Use Rehearsed Timings :Click the check box for this option if the 
timings that were set up will be used during the presentation.



• When working with PowerPoint, this tab is 
used to view the presentation in different 
formats, it is also used to view more than one 
PowerPoint window at a time, or to decide 
whether to display the ruler within the 
window.



i) Normal : Display the presentation in the normal working 
view. This is the default view for all PowerPoint 
presentations. In this view, the slide pane and thumbnails of 
the slides will be displayed.

ii) Slide Sorter :It is used to easily Rearrange the slide. To view 
the slides as thumbnails, click this button. The slides will 
appear in columns and rows. This format makes it easy to 
rearrange the slides.

iii) Notes Page : Display the presentation in notes view for 
editing the speaker notes. This view focuses on the Notes 
area. 

iv)   Slide Show : This starts the slide show.



v) Slide Master : Displays the slide master letting 
you change the design and layout of the master 
slides. When you open the Slide Master, it will 
show you a slide with many pre-set text and 
media placeholders. These are intended to make 
it easier for you to add a commonly-used slide 
element or style.

vi) Handout Master : Open handout master view to 
change the design and layout of Printed 
handouts.

vii) Notes Master : This button is used to change 
the way the notes page is displayed and printed.



i) Color : To view the presentation in color, 
choose this option. This is the default option 
for viewing presentations.

ii) Grayscale : This button is used to view the 
presentation in grayscale. Gray-scale shows 
the presentation in black and white with gray 
tones.

iii) Pure Black and White : When this option is 
chosen, the presentation will be shown in 
black and white without any gray tones.



i) New Window : To open a new PowerPoint window, click this 
button. A new window will open with the same 
presentation. The presentation will have a number after the 
name.

ii) Arrange All : Click this button to tile the open windows on 
the screen side-by-side.

iii) Cascade : Use this button to tile the open windows so that 
they overlap vertically on the screen.

iv) Move Split : This option is used to move the splitters that 
separate the different sections of the window.

v) Switch Windows : Click this button to switch from one 
window to another window. A list of the open windows will 
display when the button is clicked.





Front End Development:

The part of a website that the user interacts with 

directly is termed the front end. It is also referred 

to as the ‘client side’ of the application. 

 It includes everything that users experience 

directly: text colors and styles, images, graphs 

and tables, buttons, colors, and navigation menu. 

HTML, CSS, and JavaScript are the languages 

used for Front End development. 

The structure, design, behavior, and content of 

everything seen on browser screens when 

websites, web applications, or mobile apps are 

opened up, is implemented by front End 

developers.



Front end Languages: The front end portion is built by using some 

languages which are discussed below:

 HTML: HTML stands for Hypertext Markup Language. It is used to 

design the front-end portion of web pages using a markup language. 

HTML is the combination of Hypertext and Markup language. 

Hypertext defines the link between the web pages. The markup 

language is used to define the text documentation within the tag which 

defines the structure of web pages.

 CSS: Cascading Style Sheets fondly referred to as CSS is a simply 

designed language intended to simplify the process of making web 

pages presentable. CSS allows you to apply styles to web pages. More 

importantly, CSS enables you to do this independent of the HTML that 

makes up each web page.

 JavaScript: JavaScript is a famous scripting language used to create 

magic on the sites to make the site interactive for the user. It is used to 

enhancing the functionality of a website to running cool games and 

web-based software.



Backend Development:

 Backend is the server-side of the website. It stores and 

arranges data, and also makes sure everything on the 

client-side of the website works fine. 

 It is the part of the website that you cannot see and 

interact with. It is the portion of software that does not 

come in direct contact with the users. 

 The parts and characteristics developed by backend 

designers are indirectly accessed by users through a 

front-end application. 

 Activities, like writing APIs, creating libraries, and 

working with system components without user 

interfaces or even systems of scientific programming, 

are also included in the backend.



Back end Languages: The back end portion is built by using 

some languages which are discussed below:

 PHP: PHP is a server-side scripting language designed 

specifically for web development. Since PHP code executed on 

the server-side, so it is called a server-side scripting 

language.

 C++: It is a general-purpose programming language and 

widely used nowadays for competitive programming. It is 

also used as a backend language.

 Java: Java is one of the most popular and widely used 

programming languages and platforms. It is highly scalable. 

Java components are easily available.

 Python: Python is a programming language that lets you 

work quickly and integrate systems more efficiently.

 JavaScript: JavaScript can be used as both (front end and 

back end) programming languages.



Figure : Front-end and Back-end



What is Database?

 The database is a collection of inter-related data which is used to 

retrieve, insert and delete the data efficiently. It is also used to organize 

the data in the form of a table, schema, views, and reports, etc.

 For example: The college Database organizes the data about the 

admin, staff, students and faculty etc.

 Using the database, you can easily retrieve, insert, and delete the 

information.

What is Database Management System?

 Database management system is a software which is used to manage 

the database. For example: MySQL, Oracle, etc are a very popular 

commercial database which is used in different applications.

 DBMS provides an interface to perform various operations like 

database creation, storing data in it, updating data, creating a table in 

the database and a lot more.

 It provides protection and security to the database. In the case of 

multiple users, it also maintains data consistency.



Advantages of DBMS:
 Controls database redundancy: It can control data 

redundancy because it stores all the data in one single 
database file and that recorded data is placed in the 
database.

 Data sharing: In DBMS, the authorized users of an 
organization can share the data among multiple users.

 Easily Maintenance: It can be easily maintainable due 
to the centralized nature of the database system.

 Reduce time: It reduces development time and 
maintenance need.

 Backup: It provides backup and recovery subsystems 
which create automatic backup of data 
from hardware and software failures and restores the data 
if required.

 multiple user interface: It provides different types of 
user interfaces like graphical user interfaces, application 
program interfaces



Disadvantages of DBMS:
 Cost of Hardware and Software: It requires a high 

speed of data processor and large memory size to run 

DBMS software.

 Size: It occupies a large space of disks and large memory 

to run them efficiently.

 Complexity: Database system creates additional 

complexity and requirements.

 Higher impact of failure: Failure is highly impacted 

the database because in most of the organization, all the 

data stored in a single database and if the database is 

damaged due to electric failure or database corruption 

then the data may be lost forever.





 MS Access is a Database Management system which was 

launched by Microsoft. 

 It is a part of the Microsoft Office suite and stores data 

in its own format.

 Microsoft Access is a Database Management System 

(DBMS) from Microsoft that combines the relational 

Microsoft Jet Database Engine with a graphical user 

interface and software development tools. 

 It is a member of the Microsoft Office suite of 

applications, included in the professional and higher 

editions.



 Microsoft Access stores information which is called a 

database. To use MS Access, you will need to follow 

these four steps −

 Database Creation − Create your Microsoft Access 

database and specify what kind of data you will be 

storing.

 Data Input − After your database is created, the 

data of every business day can be entered into the 

Access database.

 Query − This is a fancy term to basically describe 

the process of retrieving information from the 

database.

 Report (optional) − Information from the database 

is organized in a nice presentation that can be 

printed in an Access Report.







❖ Tables
It is the main component of the MS Access software. In the MS Access database, tables are 
mainly used for storing the data or information in the form of rows and columns.
The Access tables which contain the data or information look similar to the tables in MS Excel 
or MS Word.
Whenever, you create a new database in MS Access, firstly, you have to create a table in that 
database. You can also relate a specific table to other tables, and easily define the primary key 
in that table.

❖ Relationships
Relationships are the links or connections, which are formed between the one or more tables in 
the database. There exist following four types of relationships:
❖ One-to-One Relationship

❖ One-to-Many Relationship

❖ Many-to-One Relationship

❖ Many-to-Many Relationship

❖ Queries
Queries are the commands, which are used to retrieve the data or information from the 
database. It also allows you to insert the information in the MS Access database.

❖ Forms
It is an object or a component, which helps the users for entering the data in the table of any 
database by an interface. Any user can easily display the data of the database.

❖ Reports
When the users inserted the data in the database, then they can easily view their information in 
an organized manner by running the reports. Unlike forms, the reports cannot be edited.

❖ Macros
Macros are used for performing the repetitive tasks on reports and forms in the MS Access 
database. It also allows the user for adding functionalities to forms, controls, and reports.

❖ Modules
Modules are used to perform the automating routine operations and user-defined functions 
which are written in VBA. Any user can easily use these modules from anywhere in the MS 
Access database.





 You can easily launch the MS-Access application in your 

Windows 10 system by following the given steps:

 Step 1: Click on the Search box in the toolbar.

 Step 2: After clicking, type the MS Access. Then, it will 

show you the icon of MS Access with the installed 

version of Microsoft office in your system. Select and 

click the icon.

 Step 3: After clicking, an application window of MS 

Access will appear on your computer screen. The 

following screenshot displays the window of MS Access 

2007.



Figure : Getting Started with ms Access



 In this section, we select the Blank Database option for 

storing the data. After clicking the option, the following 

screen will display which gives the default name of the file.



 If you are satisfied with the default file name, click on 

the Create button, otherwise change the name of a file, 

and then click on Create Button.

Figure : Naming the database



 We give the name of a file as Employee as shown in the 

above screenshot and then click the Create button. After 

clicking, the following screen will display, which shows 

that the new database is created with the given name in 

the MS Access:



Steps :
i) Click the create button on the Ribbon.

ii) Click on the table from the tables group.

iii) Click Ok.



iv) Click on the Home tab than click on view command from the

Views tab.

v) A dialog box appear. Give the name of your table.



Step 1: Firstly, you have to 

type the name of a field in the 

first column. Then, press 

the Tab button.

Step 2: Then, you have to 

choose or select the data type 

for the field from the drop-down 

list. Again, you have to press 

the Tab button. We select 

the Text data type.

Step 3: You have to repeat all 

the above three steps until all 

the fields are entered in the 

table. When all the fields are 

entered in the table, and then 

click on the Save button 

on Quick Access Toolbar.



 Once you have entered the fields and set the data types it is 

now time to enter the records in a table.

 To enter the data in a table:

1. Make sure you are in datasheet view.

2. Enter the data into the table by pressing the tab key move 

from one cell to another.

3. When you have completed the record , press enter.



 Every field in a table has properties and these 

properties define the field's characteristics and 

behavior. The most important property for a field is its 

data type. A field's data type determines what kind of 

data it can store. MS Access supports different types of 

data, each with a specific purpose.

 The data type determines the kind of the values that 

users can store in any given field.

 Each field can store data consisting of only a single data 

type.



DATA TYPES :



 If you use previous versions of Access, you will notice a difference for two of those 

data types.

 In Access 2013, we now have two data types — short text and long text. In 

previous versions of Access these data types were called text and memo.

 The text field is referred to as short text and your memo field is now called long 

text.



 The Home Tab is used to perform common Access tasks 

such as changing views when working with Tables, 

Reports, Queries, and Forms. 

 It is also possible to change Font attributes, save records, 

add new records, delete records, sort and filter records, 

check spelling, and find and/or replace data in a record.

 The Home Tab displays the most commonly used 

commands. In Access these include Copy, Cut, 

and Paste, Bold, Italic, Underscore etc. 



Click the list arrow for this button to select

from four different views while working with

the table.

1. Datasheet View : A datasheet is a useful 

way of viewing data in Access. Most 

importantly, datasheet view allows a user 

to view many table records at the same 

time. In datasheet view, information is 

displayed in rows and columns—similar to 

a spreadsheet. Records are displayed as 

rows, so each row is an individual record. 

Within each row, columns represent fields 

within the record.





2. Pivot Table View : 

 A PivotTable is an interactive table that quickly combines 

and compares large amounts of data. 

 You can rotate its rows and columns to see different 

summaries of the source data, and you can display the details 

for areas of interest. 

 Use a PivotTable when you want to analyze related totals, 

especially when you have a long list of figures to sum and you 

want to compare several facts about each figure.

 You can use the Access pivot table to make a list of unique 

values because it summarizes data that can be used to find 

unique value in a field. It’s a good way to take a quick 

overview of all the values appearing in the field and other 

inconsistencies.



STEPS TO CREATE PIVOT TABLE :
 Step 1 : Create a Database Named it as “Emp”.

 Step 2 : Create a Table Named it as “Employee”.

 Step 3 : Design the Following Table.

 Step 4 : Add The Following data into the table



Step 5 : Then Click on View Tab And Select the Pivot Table.



Step 6 : Drag the Fields that you want , the Following Pivot table is 

generated



3. Design View :

 Click on View to see Four options, Datasheet View ,Design 
View, Pivot Chart, and Pivot table. Select Design View.

 Here you can Design your table and define the data types 
of all the fields.



4. Pivot Chart : 

How to create Pivot chart?

Step 1 : Create A Table into your data base and fill the 

following data.

Step 2 : Choose the Pivot chart from the view tab.



Step 3 : Select the Fields that you want to add and create the chart.



 Sorting is of two types :

1. Sort ascending and descending

2. Sorting on more than one fields

 Filtering is of two types :

1. Common Filter

2. Filter by Selection



Sort a Table

 By sorting, you can put a column of information in alphabetical, 
numerical, or date order. 

 You can sort in ascending order (alphabetical from A to Z, 
lowest number to highest number, earliest date to latest date) 
or descending order (alphabetical from Z to A, highest number 
to lowest number, latest date to earliest date).

Steps :
 Click the column label for the column you want to sort.

 Activate the Home tab.

 Click the Ascending or Descending button in the Sort & Filter 
group. Access sorts the column in ascending or descending 
order.

To remove a sort:

 Activate the Home tab.

 Click the Clear All Sorts button in the Sort & Filter group. 
Access clears all of the sorts you have applied.



EXAMPLE OF SORTING : 

AFTER THE SORTING :



Filtering Records :

 Filters are used to allow you to narrow down your 

search to limited records in the table. Once you apply 

filters, you will see data that you want to see. Using 

filters you can direct the application to present you with 

particular tables and keep the rest away, thus not 

showing you the ones you do not want to see. The steps 

for applying filters to records are as follows:

 Go to the field you want to filter, and press the drop 

down arrow.

 A drop down menu containing check lists will show. The 

selected items will appear in the filtered results.



BEFORE FILTER

AFTER FILTER :



 Reports offer a way to view, format, and summarize 
the information in your Microsoft Access database. For 
example, you can create a simple report of phone 
numbers for all your contacts.

 Reports organize and summarize data for viewing 
online or for printing. A detail report displays all of 
the selected records. You can include summary data 
such as totals, counts, and percentages in a detail 
report. A summary report does not list the selected 
records but instead summarizes the data and presents 
totals, counts, percentages, or other summary data 
only.

 A report consists of information that is pulled from 
tables or queries, as well as information that is stored 
with the report design, such as labels, headings, and 
graphics.



HOW TO CREATE A REPORT IN MS ACCESS

 To use the Report button:

 Open the Navigation pane.

 Click the table or query on which you want to 

base your report.

 Activate the Create tab.

 Click the Report button in the Reports group. 

Access creates your report and displays your 

report in Layout view. You can modify the report.



REPORT VIEW





Section Names of Report



 A query is a request for data results, and for action on 

data. You can use a query to answer a simple question, 

to perform calculations, to combine data from different 

tables, or even to add, change, or delete table data.

 As tables grow in size they can have hundreds of 

thousands of records, which makes it impossible for the 

user to pick out specific records from that table.

 With a query you can apply a filter to the table's data, so 

that you only get the information that you want.

 Queries that you use to retrieve data from a table or to 

make calculations are called select queries.

 Queries that add, change, or delete data are called action 

queries.



Step1 : Create the Following table then goto the Create 

Ribbon and Click on Query wizard.

Step2 : A Dialog box will appear Click on simple query 

and then click on OK



Step 3 : A dialog box will appear, From here select all the 

Fields and then Click on the next button.



Step 3 : Select detail and Click on Next Button.

Step 4 : Select Modify the query and Click on Finish Button.



Step 5 : The Following Design will appear. Set the criteria 

for the state as “Enter State”.

Step 6 : save and Close the Query wizard and run the 

query Following output will be displayed



Step 7 : As we enter the criteria “Delhi” the following table is 

appeared.



 To understand what kind of data you can import in the 
Access data, let us open your database and go to the 
External Data tab.

 In the import & Link group, you can see the different 
kind of options available for data import in Access. 
Following are the most commonly used data import 
formats.

1. Microsoft Office Excel

2. Microsoft Office Access

3. Text files (delimited or fixed-width)

4. XML Files



STEPS TO IMPORT DATA FROM MS EXCEL :
 Step 1 : Create the Following table in Microsoft Excel.

 Step 2 : Close the Excel File and Open the Microsoft 

Access.

 Step 3 : Click on Excel Icon In External data Tab.



 Step 4 : Browse the Location of the excel file, Then Click on OK button.

 Step 5 : click on the next button in following Window.



 Step 6 : Set the data types for every Field and then click on next button.

 Step 7 : Add the primary key to your table and then click on Next button.



 Step 8 : Give the table name and click on the finish button a 

ImportingStudent.

 Step 9 : The following table will appear on your access screen.



TOPIC : EXPORTING DATA FROM ACCESS TO EXCEL AND WORD

 Microsoft Access is an efficient program for creating and 

maintaining databases. You can use Excel spreadsheets to 

manipulate and assess the data that is kept in an Access 

table. 

 Microsoft has made it simple for the Office applications to 

collaborate with each other to do various things. Exporting 

your data from Microsoft Access to be analyzed in Excel 

takes only a few minutes.



STEPS HOW TO EXPORT DATA FROM MS ACCESS TO EXCEL

 Step 1 : Create the following table in your MS Access 

database.

 Click on the Excel button which is present in Export Group 

in Export tab.



 Step 3 : Select the location of the file and then click on “OK” 

Button



 Step 4 : Go to the location of the file and open the excel file.    



STEPS HOW TO EXPORT DATA FROM MS ACCESS TO WORD

 Step 1 : Create the following table in your MS Access 

database.

 Click on the Word button which is present in Export Group 

in Export tab.



 Step 3 : Select the location of the file and then click on “OK” 

Button



 Step 4 : Go to the location of the file and open the word file.    



Creating a Form using a form Wizard: A form is a 

database object that is used to enter or display data 

in a database.

To Create form using the wizard follow the 

following steps :

Navigate to the table you want to base the form on.

Click Create on the ribbon.

Click Forms.

You are able to navigate using the navigation arrow 

at the bottom of the form



FORM DESIGN :

To enter the record on the Form :

•Click the View button on the ribbon to switch from layout 

view To form view.

•Enter the data for each field in the record, Pressing the enter 

key to move to the end field.

•Press enter after you have entered data for the last field, 

This will send the record to the table. 



 One of the goals of good database design is to remove data 

redundancy.

 To achieve that goal, you divide your data into many subject-

based tables so that each fact is represented only once.

 To do this, all the common fields which are related to each 

other are placed in one table.

 To do this step correctly, you must first understand the 

relationship between your tables, and then specify these 

relationships in your Access database.

Why Create Table Relationships?

 MS Access uses table relationships to join tables when you 

need to use them in a database object. There are several 

reasons why you should create table relationships before you 

create other database objects, such as forms, queries, macros, 

and reports.



 When you design a form or report, MS Access uses 
the information it gathers from the table 
relationships you have already defined to present 
you with informed choices and to prepopulate
property settings with appropriate default values.

 When you design a database, you divide your 
information into tables, each of which has a primary 
key and then add foreign keys to related tables that 
reference those primary keys.

 These foreign key-primary key pairings form the 
basis for table relationships and multi-table queries.

 To work with records from more than one table, you 
often must create a query that joins the tables.

 The query works by matching the values in the 
primary key field of the first table with a foreign key 
field in the second table.



 Table relationships : In access we store data in multiple 

tables and then use relationships to join the tables.

Create a relationship in an access desktop database :

Step 1 : Create a Table with following data types of the 

field.

Step 2 : enter the following data in the table.



Step 3 : Create a 2nd table with the following fields and data 

types.

Step 4 : Enter the following data into the table.

Step 5 : Go to the database tools and then click on relationship 

button



Step 6 : Select the common field from both the tables and then 

click on OK button.

Step 7 : the following relationship will generated, after creating 

the relationship save the relationship.



What are Keys in DBMS?

 KEYS in DBMS is an attribute or set of attributes which helps 
you to identify a row(tuple) in a relation(table). They allow you to 
find the relation between two tables. 

 Keys help you uniquely identify a row in a table by a combination 
of one or more columns in that table. Key is also helpful for finding 
unique record or row from the table. Database key is also helpful 
for finding unique record or row from the table.

 Why we need a Key?

Here are some reasons for using any Database key in the DBMS 
system.

 Keys help you to identify any row of data in a table. In a real-world 
application, a table could contain thousands of records. Moreover, 
the records could be duplicated. Keys ensure that you can uniquely 
identify a table record despite these challenges.

 Allows you to establish a relationship between and identify the 
relation between tables

 Help you to enforce identity and integrity in the relationship.





1. Primary key

 It is the first key which is used to identify one and only one instance of an 

entity uniquely. An entity can contain multiple keys as we saw in 

PERSON table. The key which is most suitable from those lists become a 

primary key.

 In the EMPLOYEE table, ID can be primary key since it is unique for 

each employee. In the EMPLOYEE table, we can even select 

License_Number and Passport_Number as primary key since they are 

also unique.



2. Candidate key

 A candidate key is an attribute or set of an attribute which 

can uniquely identify a tuple.

 The remaining attributes except for primary key are 

considered as a candidate key. The candidate keys are as 

strong as the primary key.

 For example: In the EMPLOYEE table, id is best suited for 

the primary key. Rest of the attributes like SSN, 

Passport_Number, and License_Number, etc. are considered 

as a candidate key.



3. Super key :

 Super key is a set of an attribute which can uniquely 

identify a tuple. Super key is a superset of a candidate key.

 A superkey is a group of single or multiple keys which 

identifies rows in a table. A Super key may have additional 

attributes that are not needed for unique identification.

 Example:

 In the above-given example, EmpSSN and EmpNum name 

are superkeys.



4. Foreign key

 Foreign keys are the column of the table which is used to point to the 

primary key of another table.

 In a company, every employee works in a specific department, and 

employee and department are two different entities. So we can't store the 

information of the department in the employee table. That's why we link 

these two tables through the primary key of one table.

 We add the primary key of the DEPARTMENT table, Department_Id as a 

new attribute in the EMPLOYEE table.

 Now in the EMPLOYEE table, Department_Id is the foreign key, and 

both the tables are related.





• Multimedia is an interactive media and provides multiple ways to 
represent information to the user in a powerful manner. It 
provides an interaction between users and digital information. 

• It is a medium of communication. Some of the sectors where 
multimedia is used extensively are education, training, reference 
material, business presentations, advertising and documentaries.

• The information presented through multimedia has better quality 
and capability, as it can be understood easily.

Literal Meaning of Multimedia

• Multi − it means more than one

• Medium − it is singular and it means intermediary or mean

• Media − it is plural and it means conveying the information

• Likewise, Multimedia is the field of Computer Science that 
integrates different forms of information and represents in the 
form of audio, video, and animation along with the traditional 
media, i.e., text, graphics/drawings, images, etc.



• By definition Multimedia is a representation of 
information in an attractive and interactive manner 
with the use of a combination of text, audio, video, 
graphics and animation. 

• In other words we can say that Multimedia is a 
computerized method of presenting information 
combining textual data, audio, visuals (video), 
graphics and animations. 

• For examples: E-Mail, Yahoo Messenger, Video 
Conferencing, and Multimedia Message Service 
(MMS).







• Computer animation is a modern technology, which helps in creating, 
developing, sequencing, and displaying a set of images (technically 
known as ‘frames’). Animation gives visual effects or motion very 
similar to that of a video file (see image given below).

• The illusion of motion created by the consecutive display of images of 
static elements.

• In multimedia, animation is used to further enhance / enriched the 
experience of the user to further understand the information 
conveyed to them.



• Any two-dimensional figure or illustration

• Could be produced manually (by drawing, 
painting, carving, etc.) or by computer graphics 
technology.

• Used in multimedia to show more clearly what 
a particular information is all about (diagrams, 
picture).



There are two types of Graphics:

• Bitmap images- Bitmap images are real images 
that can be captured from devices such as digital 
cameras or scanners. Generally bitmap images 
are not editable. Bitmap images require a large 
amount of memory.

• Vector Graphics- Vector graphics are drawn on 
the computer and only require a small amount of 
memory. These graphics are editable.



• A multimedia application may require the use of speech, 
music and sound effects. These are called audio or 
sound element of multimedia. Speech is also a perfect 
way for teaching. 

• Audio are of analog and digital types. Analog audio or 
sound refers to the original sound signal. Computer 
stores the sound in digital form. Therefore, the sound 
used in multimedia application is digital audio.



• This technology records, synthesizes, and displays images (known as 
frames) in such sequences (at a fixed speed) that makes the creation 
appear as moving; this is how we see a completely developed video. 
In order to watch a video without any interruption, video device must 
display 25 to 30 frames/second.

• Is the technology of capturing, recording, processing, transmitting, 
and reconstructing moving pictures.

• Video is more towards photo realistic image sequence or live 
recording as in comparison to animation.



• Let us now see the different fields where multimedia is 
applied. The fields are described in brief below −

1. Presentation :
• With the help of multimedia, presentation can be made 

effective.
2. E-books :
• Today, books are digitized and easily available on the 

Internet.
3. Digital Library :
• The need to be physically present at a library is no more 

necessary. Libraries can be accessed from the Internet also. 
Digitization has helped libraries to come to this level of 
development.

4. E-learning :
• Today, most of the institutions (public as well as private 

both) are using such technology to education people.



5. Movie making

• Most of the special effects that we see in any movie, is only 
because of multimedia technology.

6. Video games

• Video games are one of the most interesting creations of 
multimedia technology. Video games fascinate not only the 
children but adults too.

7. Animated films

• Along with video games, animated film is another great 
source of entertainment for children.

8. Multimedia conferencing

• People can arrange personal as well as business meetings 
online with the help of multimedia conferencing technology.

9. E-shopping

• Multimedia technology has created a virtual arena for the e-
commerce.



Following are the common areas of applications of multimedia.
• Multimedia in Business- Multimedia can be used in many applications in a 

business. The multimedia technology along with communication technology 
has opened the door for information of global wok groups. Today the team 
members may be working anywhere and can work for various companies. 
Thus the work place will become global. The multimedia network should 
support the following facilities:
– Voice Mail
– Electronic Mail
– Multimedia based FAX
– Office Needs
– Employee Training
– Sales and Other types of Group Presentation
– Records Management

• Multimedia in Marketing and Advertising- By using multimedia marketing 
of new products can be greatly enhanced. Multimedia boost 
communication on an affordable cost opened the way for the marketing 
and advertising personnel. Presentation that have flying banners, video 
transitions, animations, and sound effects are some of the elements used in 
composing a multimedia based advertisement to appeal to the consumer in 
a way never used before and promote the sale of the products.



• Multimedia in Entertainment- By using multimedia 
marketing of new products can be greatly enhanced. 
Multimedia boost communication on an affordable cost 
opened the way for the marketing and advertising personnel. 
Presentation that have flying banners, video transitions, 
animations, and sound effects are some of the elements used 
in composing a multimedia based advertisement to appeal to 
the consumer in a way never used before and promote the 
sale of the products.

• Multimedia in Education- Many computer games with focus 
on education are now available. Consider an example of an 
educational game which plays various rhymes for kids. The 
child can paint the pictures, increase reduce size of various 
objects etc apart from just playing the rhymes.Several other 
multimedia packages are available in the market which 
provide a lot of detailed information and playing capabilities 
to kids.



• Multimedia in Hospital- Multimedia best use in hospitals is for real 
time monitoring of conditions of patients in critical illness or 
accident. The conditions are displayed continuously on a computer 
screen and can alert the doctor/nurse on duty if any changes are 
observed on the screen. Multimedia makes it possible to consult a 
surgeon or an expert who can watch an ongoing surgery line on his 
PC monitor and give online advice at any crucial juncture.

• In hospitals multimedia can also be used to diagnose an illness with 
CD-ROMs/ Cassettes/ DVDs full of multimedia based information 
about various diseases and their treatment.Some hospitals 
extensively use multimedia presentations in training their junior staff 
of doctors and nurses. Multimedia displays are now extensively used 
during critical surgeries.



Communication Technology and Multimedia Services-

• The advancement of high computing abilities, 
communication ways and relevant standards has started 
the beginning of an era where you will be provided with 
multimedia facilities at home. These services may include:

– Basic Television Services

– Interactive entertainment

– Digital Audio

– Video on demand

– Home shopping

– Financial Transactions

– Interactive multiplayer or single player games

– Digital multimedia libraries

– E-Newspapers, e-magazines



• Animation is the process of designing, drawing, making 
layouts and preparation of photographic sequences which are 
integrated in the multimedia and gaming products. 

• Animation involves the exploitation and management of still 
images to generate the illusion of movement. A person who 
creates animations is called animator.

• Animation is a method of photographing successive 
drawings, models, or even puppets, to create an illusion of 
movement in a sequence. Because our eyes can only retain an 
image for approx. 1/10 of a second, when multiple images 
appear in fast succession, the brain blends them into a single 
moving image. 

• In traditional animation, pictures are drawn or painted on 
transparent celluloid sheets to be photographed. Early 
cartoons are examples of this, but today, most animated 
movies are made with computer-generated imagery or CGI.



The Animation is basically of 5 Types 

1. Traditional Animation

2. 2D Animation

3. 3D Animation

4. Motion Graphics

5. Stop Motion



• Traditional animation can also be referred to as cell animation. 

• This type of animation requires the animator to draw every single 
frame by hand to create an animated scene. 

• This is usually done on a light table that allows the artists to see the 
previous drawing through the top layer of paper. 

• Well-known companies like Disney are known for using this type of 
animation. Traditional animation is still done today on computers 
with special tablets.



• 2D animation is also referred as two dimensional 
animation. It provides the dynamic activeness for 
static image.

• These Program are directed by Vector or Bitmap 
images.

• Dynamic working of animation is set by viewer by 
putting a series of frame. To smoothly run of an 
animation we need to set the frame at 15 frames/ 
Per sec.

• It gives more flexibility to beginners in animation 
because they don’t have to rely so heavily on 
drawing skills.



• 3D animation is also known as computer animation and it is 
currently the most commonly used form of animation. 

• The process of 3D animation is very different from the traditional 
style but they both require the artist to share the same principles 
of movement and composition in animation. 

• 3D animation has less to do with drawing and more to do with 
moving a character in a program. 

• The National Science Foundation emphasizes how heavily 3D 
animators must rely on physics to create realistic animations. The 
animator creates keyframes or specific movements and lets the 
computer fill in the rest.



• Unlike the previously mentioned types of 
animation, motion graphics are not driven by 
characters or storylines. This art form focuses on 
the ability to move graphic elements, shapes, and 
text. This process is commonly used for things like 
television promotions, explainer videos, and 
animated logos. 



• Stop motion animation is very similar to traditional animation 
because it combines a series of still images that are slightly different 
to show movement. 

• The largest difference is that stop motion uses photography and 
captures real objects. With stop motion, the artists take a photo of an 
object or scene and slightly moves the objects before taking another 
photo. 

• The artist repeats this process until the scene is completed and uses 
each photo as a frame in the animation. It’s similar to a flipbook with 
photos.



01. Squash and stretch :

The squash and stretch principle is considered the most important of 
the 12 principles of animation. When applied, it gives your animated 
characters and objects the illusion of gravity, weight, mass and 
flexibility. Think about how a bouncing rubber ball may react when 
tossed into the air: the ball stretches when it travels up and down 
and squishes when it hits the ground.



02. Anticipation

• Anticipation helps to prepare the viewer for what's about to happen. 
When applied, it has the effect of making the object's action more 
realistic.

• Consider how if might look if you were to jump in the air without 
bending your knees, or perhaps to throw a ball without first pulling 
your arm back. It would appear very unnatural (it may not even be 
possible to jump without bending your knees!). In the same way, 
animating movements without a flicker of anticipation will also make 
your motion seem awkward, stale and lifeless.



03. Staging :

• Staging in animation is a lot like composition in artwork. 
What we mean by that is, you should use motion to guide 
the viewer's eye and draw attention to what's important 
within the scene. 

• Keep the focus on what's important within the scene, and 
keep the motion of everything else of non-importance to a 
minimum.



04. Straight ahead action and pose to pose

• There are two ways to handle drawing animation: straight 
ahead and pose to pose. Each has its own benefits, and the 
two approaches are often combined. 

• Straight Ahead : Straight ahead action involves drawing 
frame-by-frame from start to finish. If you're looking for 
fluid, realistic movements, straight ahead action is your 
best bet.



• Pose to Pose :With the pose to pose technique, you 
draw the beginning frame, the end frame, and a few 
key frames in-between. Then you go back and 
complete the rest. This technique gives you a bit 
more control within the scene and allows you to 
increase the dramatic effect of the motion.
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05. Follow through and overlapping action :

• When objects come to a standstill after being in motion, different 
parts of the object will stop at different rates. Similarly, not 
everything on an object will move at the same rate. This forms the 
essence of the fifth of Disney's principles of animation.

• If your character is running across the scene, their arms and legs may 
be moving at a different rate from their head. This is overlapping 
action. Likewise, when they stop running, their hair will likely 
continue to move for a few frames before coming to rest – this is 
follow through. These are important principles to understand if you 
want your animation to flow realistically.



06. Slow in and slow out

• The best way to understand slow in and slow out is 
to think about how a car starts up and stops. It will 
start moving slowly, before gaining momentum and 
speeding up. The reverse will happen when the car 
brakes. In animation, this effect is achieved by 
adding more frames at the beginning and end of an 
action sequence. Apply this principle to give your 
objects more life. 



07. Arc

• When working in animation, it's best to stick with 
the laws of physics. Most objects follow an arc or a 
path when they're moving, and your animations 
should reflect that arc. For example, when you toss 
a ball into the air, it follows a natural arc as the 
effects of the Earth's gravity act upon it.



08. Secondary action

• Secondary actions are used to support or emphasize the 
main action going on within a scene. Adding secondary 
actions help add more dimension to your characters and 
objects.

• For instance, the subtle movement of your character’s hair 
as they walk, or perhaps a facial expression or a secondary 
object reacting to the first. Whatever the case may be, this 
secondary action should not distract from the primary one.



09. Timing

• For this principle of animation we need to look to the laws of physics 
again, and apply what we see in the natural world to our animations. 
In this case, the focus is on timing.

• If you move an object more quickly or slowly than it would naturally 
move in the real world, the effect won't be believable. Using the 
correct timing allows you to control the mood and the reaction of 
your characters and objects. 



10. Exaggeration :

• Too much realism can ruin an animation, making it 
appear static and boring. Instead, add some 
exaggeration to your characters and objects to 
make them more dynamic. Find ways to push the 
limits just beyond what's possible, and your 
animations will pop.



11. Solid drawing

• You need to understand the basics of drawing. This includes 
knowing how to draw in three-dimensional space and 
understanding form and anatomy, weight and volume, and 
lights and shadows.

• While you can push the limits here, too, it's important to 
remain consistent. If your world has wonky doors and a 
warped perspective, keep that perspective throughout the 
entire animation. Otherwise, things will fall apart.



12. Appeal

• Your characters, objects, and the world in which they live 
need to appeal to the viewer. This includes having an easy-
to-read design, solid drawing, and a personality. There is no 
formula for getting this right, but it starts with strong 
character development and being able to tell your story 
through the art of animation.



Hardware resources requirements for animations :

• Hardware requirements same for both 2D and 3D 
animations but software resources are different.



Software Requirements : 
2D animations software :
1. Flash
2. Pencil2D
3. Synfig Studio
4. CrazyTalk Animator
5. Blender 2D Animation
6. CrazyTalk Animator 3
7. Digicel Flipbook
8. Opentoonz
9. CelAction 2D
10. Moho Pro
11. Animaker
12. PicsArt
13. Draw Cartoons 2 Pro
14. FlipaClip
15. Stop Motion Studio
16. RoughAnimator



3D animation software :
1. Beginner : If you want something for nothing, there are a few 

freeware versions of 3D package available.
i) 3D Convas
ii) XARA 3D 
iii) Adobe Dimension
2. Intermediate : If you want a good quality of your 3d animation, 

than you have to use following.
i) Strata 3D Pixel
ii) Blender
iii) Coral’s bryce 3D
3. Advanced : If you want to generate high level 3D application 

than you have to use.
i) newtek’s lightwave 3D
ii) Softimages x SI
iii) Alian’s MAYA 3D
iv) Discrete’s 3Ds max and houdine



1. .MPEG – Moving Pictures Experts Group

2. .GIF – Graphics Interchange Format

3. .JPEG – Joint Photographic experts group

4. .MP4 

5. .TIFF – Tagged Image file format 

6. .FLV – Flash Video File



• An MPEG file is a video file that uses a digital video format 
standardized by the Moving Picture Experts Group (MPEG). 
It contains video and audio that are compressed using 
MPEG-1 or MPEG-2 compression. MPEG files are typically 
used to share videos over the Internet.

• MPEG-1 – Audio/video standards designed for digital storage 
media (such as an MP3 file)

• MPEG-2 – Standards for digital television and DVD video
• MPEG-4 – Multimedia standards for the computers, mobile 

devices, and the web
• MPEG-7 – Standards for the description and search of 

multimedia content
• MPEG-MAR – A mixed reality and augmented 

reality reference model
• MPEG-DASH – Standards that provide solutions for streaming 

multimedia data over HTTP (such as servers and CDNs)



• Using MPEG compression, the file size of 
a multimedia file can be significantly reduced with 
little noticeable loss in quality. 

• This makes transferring files over the Internet more 
efficient, which helps conserve Internet bandwidth.

• MPEG compression is so ubiquitous that the term 
"MPEG" is commonly used to refer to a 
video file saved in an MPEG file format rather than 
the organization itself. These files usually have a 
".mpg" or ".mpeg" file extension.



• An MP4 file is a multimedia file commonly used to 
store a movie or video clip. It may also contain subtitles 
or images. 

• MP4 is short for MPEG-4 Part 14, which is a container 
format based on the QuickTime File Format (QTFF) 
used by .MOV and .QT files.

• MP4 files use MPEG-4 compression, a standard 
developed by the Moving Picture Experts Group 
(MPEG). 

• This format includes separate compression for audio 
and video tracks. Video is compressed with MPEG-4 
video encoding and audio is compressed using AAC 
compression, which is the same type of audio 
compression used in .AAC files.



• Developer : CompuServe
• Category : Raster Image Files
• Format : Binary
• A GIF file is an image file saved in the Graphical Interchange 

Format (GIF). It may contain up to 256 indexed colors with a 
color palette that may be a predefined set of colors or may be 
adapted to the colors in the image. 

• GIF files are saved in a lossless format, meaning the clarity of 
the image is not compromised with GIF compression.

• GIFs are a common format for web graphics, especially small 
images and images that contain text, such as navigation 
buttons. However, JPEG (.JPG) images are better for showing 
photos because they are not limited in the number of colors 
they can display.

• GIF images can also be animated and saved as "animated 
GIFs," which are often used to display basic animations on 
websites.



• Developer : Joint Photographic Experts Group

• Category : Raster Image Files

• Format : Binary

• A JPEG file is an image saved in a compressed graphic 
format standardized by the Joint Photographic Experts 
Group (JPEG). 

• It supports up to 24-bit color and is compressed 
using lossy compression, which may noticeably reduce 
the image quality if high amounts of compression are 
used. 

• JPEG files are commonly used for storing digital photos 
and web graphics.



• In the early 1980s, no technology existed that allowed 
users to easily compress and share digital images with 
one another. 

• In 1982, the JPEG workgroup began designing a 
compression standard that could be used to reduce 
image files' size, making them easier to share, while 
retaining as much of their quality as possible.

• In 1992, the workgroup created the JPEG file format. 
• JPEG files are images created using a lossy compression 

algorithm, which actually destroys some data 
contained within the original image file. However, this 
data loss is mostly unnoticeable to the human eye.



• Developer : Adobe Systems
• Category : Raster Image Files
• Format : Text and Binary
• A TIF file contains an image saved in the Tagged Image File Format 

(TIFF), a high-quality graphics format. It is often used for storing 
images with many colors, typically digital photos, and includes 
support for layers and multiple pages.

• The TIFF format was created in the mid-1980s to be a universal 
image format for different computer platforms and document 
scanners. 

• The format became popular among professionals in the publishing 
industry, including photographers and graphic artists. The 
popularity of the format was partially due to its ability to be edited 
and re-saved without losing image quality.

• TIF files can be saved in an uncompressed (lossless) format or may 
incorporate .JPEG (lossy) compression. 

• They may also use LZW lossless compression, which reduces the 
TIF file size but does not reduce the quality of the image.



• Developer : Adobe Systems
• Category : Video Files
• Format : Binary
• An FLV file is a video file saved in the Adobe Flash 

Video (FLV) container format. 
• It stores a short header, synchronized audio and video 

data streams (encoded the same way as streams in 
the standard Flash .SWF format), 
and metadata packets.

• The FLV format was introduced with the release of 
Adobe Flash Player 7 in 2003. It is primarily utilized by 
Adobe Flash Player for delivering video content, such 
as movies and TV shows, online. 

• However, FLV is an open format that is also supported 
by various non-Adobe/Macromedia programs.


